[bug#34254] build: clean-go: Do not warn about *.go files in "test-tmp".

Message ID 20190130050858.12859-1-ericbavier@centurylink.net
State Accepted
Commit 92becc3f15ce196a94274f80ee0b6594774856fa
Headers show
Series [bug#34254] build: clean-go: Do not warn about *.go files in "test-tmp". | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Eric Bavier Jan. 30, 2019, 5:08 a.m. UTC
From: Eric Bavier <bavier@member.fsf.org>

* Makefile.am (clean-go): Ignore "test-tmp" directory.
---
 Makefile.am | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Feb. 6, 2019, 10:04 p.m. UTC | #1
ericbavier@centurylink.net skribis:

> From: Eric Bavier <bavier@member.fsf.org>
>
> * Makefile.am (clean-go): Ignore "test-tmp" directory.

Neat, go for it!  This had been annoying me for a while actually…

Thanks,
Ludo’.
Eric Bavier Feb. 8, 2019, 3:22 a.m. UTC | #2
On Wed, 06 Feb 2019 23:04:36 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

> ericbavier@centurylink.net skribis:
> 
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > * Makefile.am (clean-go): Ignore "test-tmp" directory.  
> 
> Neat, go for it!  This had been annoying me for a while actually…
> 
> Thanks,
> Ludo’.

Pushed to master in 92becc3f15ce196a94274f80ee0b6594774856fa

`~Eric

Patch

diff --git a/Makefile.am b/Makefile.am
index 0590c51519..fec9800ce7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -318,7 +318,7 @@  nobase_nodist_guileobject_DATA = $(GOBJECTS)
 # Handy way to remove the .go files without removing all the rest.
 clean-go:
 	-$(RM) -f $(GOBJECTS)
-	@find . -name '*.go' -print | \
+	@find . -path ./test-tmp -prune -o -name '*.go' -print | \
 	  if test -t 1; then \
 	    xargs -r echo -e "\033[31mwarning:\033[0m stray .go files:"; \
 	  else \