[bug#34205] gnu: Add lhasa.

Message ID 20190126012444.19033-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#34205] gnu: Add lhasa. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Kei Kebreau Jan. 26, 2019, 1:24 a.m. UTC
* gnu/packages/compression.scm (lhasa): New variable.
---
 gnu/packages/compression.scm | 35 ++++++++++++++++++++++++++++++++++-
 1 file changed, 34 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus Jan. 26, 2019, 12:09 p.m. UTC | #1
Hi Kei,

> * gnu/packages/compression.scm (lhasa): New variable.

this looks good to me.

A few minor suggestions:

> +    (home-page "http://fragglet.github.com/lhasa/")

Please use HTTPS.

> +    (synopsis "LHA implementation")

I’d prefer “Parse LHA archives” or something else that hints at what
“LHA” is.

> +    (description "Lhasa is a replacement for the Unix LHA tool, for
> +decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives.  The backend for the
> +tool is a library, so that it can be reused for other purposes.  Lhasa aims to
> +be compatible with as many types of lzh/lzs archives as possible.  It also aims
> +to generate the same output as the (non-free) Unix LHA tool, so that it will
> +act as a drop-in free replacement.")

I’d say “free drop-in replacement”.

Patch

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 327951fde..3fe4c74ec 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -12,7 +12,7 @@ 
 ;;; Copyright © 2016 Danny Milosavljevic <dannym@scratchpost.org>
 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 David Craven <david@craven.ch>
-;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2016, 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
 ;;; Copyright © 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
@@ -434,6 +434,39 @@  than gzip and 15 % smaller output than bzip2.")
    (license (list license:gpl2+ license:lgpl2.1+)) ; bits of both
    (home-page "https://tukaani.org/xz/")))
 
+(define-public lhasa
+  (package
+    (name "lhasa")
+    (version "0.3.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://github.com/fragglet/lhasa/releases/download/v"
+                    version "/lhasa-" version ".tar.gz"))
+              (sha256
+               (base32
+                "092zi9av18ma20c6h9448k0bapvx2plnp292741dvfd9hmgqxc1z"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'set-up-test-environment
+           (lambda* (#:key inputs #:allow-other-keys)
+             (setenv "TZDIR" (string-append (assoc-ref inputs "tzdata")
+                                            "/share/zoneinfo"))
+             #t)))))
+    (native-inputs
+     `(("tzdata" ,tzdata)))
+    (home-page "http://fragglet.github.com/lhasa/")
+    (synopsis "LHA implementation")
+    (description "Lhasa is a replacement for the Unix LHA tool, for
+decompressing .lzh (LHA / LHarc) and .lzs (LArc) archives.  The backend for the
+tool is a library, so that it can be reused for other purposes.  Lhasa aims to
+be compatible with as many types of lzh/lzs archives as possible.  It also aims
+to generate the same output as the (non-free) Unix LHA tool, so that it will
+act as a drop-in free replacement.")
+    (license license:isc)))
+
 (define-public lzo
   (package
     (name "lzo")