[bug#34200] gnu: Add stoken.

Message ID 20190125193128.13038-1-ericbavier@centurylink.net
State Accepted
Headers show
Series [bug#34200] gnu: Add stoken. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Eric Bavier Jan. 25, 2019, 7:31 p.m. UTC
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/crypto.scm (stoken): New variable.
---
 gnu/packages/crypto.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

Comments

Ricardo Wurmus Jan. 26, 2019, 1:53 p.m. UTC | #1
Hi Eric,

thanks for the patch!

> * gnu/packages/crypto.scm (stoken): New variable.
[…]
> +    (home-page "https://stoken.sf.net")

Sourceforge home pages don’t seem to support HTTPS.

> +    (synopsis "Software Token for cryptographic authentication")
> +    (description
> +     "@code{stoken} is a tokencode generator compatible with RSA SecurID
> +128-bit (AES) tokens.  This package contains a standalong command-line program
> +that allows for importing token seeds, generating tokencodes, and various
> +utility/testing functions.")
> +    (license license:lgpl2.1+)))

“standalong” should be “standalone”; I’d also separate the term
“tokencodes”.

Other than that it looks good to me!

--
Ricardo
Eric Bavier Jan. 26, 2019, 11:48 p.m. UTC | #2
On Sat, 26 Jan 2019 14:53:49 +0100
Ricardo Wurmus <rekado@elephly.net> wrote:

> Hi Eric,
> 
> thanks for the patch!
> 
> > * gnu/packages/crypto.scm (stoken): New variable.  
> […]
> > +    (home-page "https://stoken.sf.net")  
> 
> Sourceforge home pages don’t seem to support HTTPS.

Hm, transcription error, I guess.

> 
> > +    (synopsis "Software Token for cryptographic authentication")
> > +    (description
> > +     "@code{stoken} is a tokencode generator compatible with RSA SecurID
> > +128-bit (AES) tokens.  This package contains a standalong command-line program
> > +that allows for importing token seeds, generating tokencodes, and various
> > +utility/testing functions.")
> > +    (license license:lgpl2.1+)))  
> 
> “standalong” should be “standalone”; I’d also separate the term
> “tokencodes”.

Done.

> 
> Other than that it looks good to me!

Thanks for the review, Ricardo!

Pushed with fixes to master in c2ab3b84398df0b26e6127ea0c336a39e8950d17.

`~Eric

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 2c63e53191..a41543289c 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -5,7 +5,7 @@ 
 ;;; Copyright © 2016 Lukas Gradl <lgradl@openmailbox>
 ;;; Copyright © 2016, 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
-;;; Copyright © 2016, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2016, 2017, 2019 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2017 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
@@ -902,3 +902,29 @@  Features:
 @end itemize\n")
       (home-page "https://github.com/bitcoin-core/secp256k1")
       (license license:unlicense))))
+
+(define-public stoken
+  (package
+    (name "stoken")
+    (version "0.92")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/stoken/"
+                                  "stoken-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0npgr6y85gzwksy8jkwa4yzvqwjprwnplx3yiw3ayk4f0ldlhaxa"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("nettle" ,nettle)
+       ("libxml2" ,libxml2)))
+    (home-page "https://stoken.sf.net")
+    (synopsis "Software Token for cryptographic authentication")
+    (description
+     "@code{stoken} is a tokencode generator compatible with RSA SecurID
+128-bit (AES) tokens.  This package contains a standalong command-line program
+that allows for importing token seeds, generating tokencodes, and various
+utility/testing functions.")
+    (license license:lgpl2.1+)))