[bug#34175,2/4] gnu: Add sbsigntools.

Message ID 20190123000304.11385-2-dannym@scratchpost.org
State Accepted
Headers show
Series Add EFI tools. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Danny Milosavljevic Jan. 23, 2019, 12:03 a.m. UTC
* gnu/packages/efi.scm (sbsigntools): New variable.
---
 gnu/packages/efi.scm | 65 ++++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 65 insertions(+)

Comments

Ricardo Wurmus Jan. 23, 2019, 8:08 a.m. UTC | #1
Danny Milosavljevic <dannym@scratchpost.org> writes:

> * gnu/packages/efi.scm (sbsigntools): New variable.
[…]
> +         (add-after 'unpack 'setenv
> +           (lambda _
> +             (setenv "CC" "gcc")
> +             #t)))))

Could this be done via #:make-flags instead?
Danny Milosavljevic Jan. 23, 2019, 2:09 p.m. UTC | #2
Hi Ricardo,

On Wed, 23 Jan 2019 09:08:18 +0100
Ricardo Wurmus <rekado@elephly.net> wrote:

> Danny Milosavljevic <dannym@scratchpost.org> writes:
> 
> > * gnu/packages/efi.scm (sbsigntools): New variable.  
> […]
> > +         (add-after 'unpack 'setenv
> > +           (lambda _
> > +             (setenv "CC" "gcc")
> > +             #t)))))  
> 
> Could this be done via #:make-flags instead?

No, they call a submake in a shellscript and via "make"
rather than "${MAKE} ${MAKEFLAGS}", so the option will get lost
along the way.

Patch

diff --git a/gnu/packages/efi.scm b/gnu/packages/efi.scm
index 3a92370ef..124a4bef8 100644
--- a/gnu/packages/efi.scm
+++ b/gnu/packages/efi.scm
@@ -17,9 +17,16 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages efi)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages bash)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages man)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages tls)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix build-system gnu)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix utils))
 
@@ -50,3 +57,61 @@  environment presented by Intel's EFI.")
     (home-page "https://directory.fsf.org/wiki/GNU_EFI")
     ;; FIXME: https://metadata.ftp-master.debian.org/changelogs/main/g/gnu-efi/gnu-efi_3.0.9-1_copyright
     (license license:gpl2)))
+
+(define-public sbsigntools
+  (package
+    (name "sbsigntools")
+    (version "0.9.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git")
+         (commit (string-append "v" version))
+         (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "116649ixr6gvw9fqiljfflxsv4293hgm73bmba5ilxrzn4kpbzvb"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-more-shebangs
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "lib/ccan.git/tools/create-ccan-tree"
+              (("#!/bin/bash")
+               (string-append "#!"
+                              (assoc-ref inputs "bash")
+                              "/bin/bash")))
+             #t))
+         (add-after 'unpack 'patch
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (substitute* '("configure.ac"
+                            "tests/Makefile.am")
+              (("/usr/include/efi")
+               (string-append (assoc-ref inputs "gnu-efi")
+                              "/include/efi"))
+              (("/usr/lib/gnuefi")
+               (string-append (assoc-ref inputs "gnu-efi")
+                              "/lib")))
+             #t))
+         (add-after 'unpack 'setenv
+           (lambda _
+             (setenv "CC" "gcc")
+             #t)))))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("bash" ,bash)
+       ("help2man" ,help2man)
+       ("pkg-config" ,pkg-config)
+       ("util-linux" ,util-linux))) ; getopt
+    (inputs
+     `(("gnu-efi" ,gnu-efi)
+       ("openssl" ,openssl)))
+    (synopsis "EFI signing tools")
+    (description "This package provides tools for signing EFI binaries.")
+    (home-page "https://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git/")
+    (license license:gpl3+)))