[bug#34057] core-updates -- gnu: groff: Fix doc installation.

Message ID 20190113071850.14337-2-ericbavier@centurylink.net
State Accepted
Headers show
Series [bug#34057] core-updates -- gnu: groff: Fix doc installation. | expand

Checks

Context Check Description
cbaines/package builds pending In Cuirass
cbaines/applying patch fail Apply failed

Commit Message

Eric Bavier Jan. 13, 2019, 7:18 a.m. UTC
From: Eric Bavier <bavier@member.fsf.org>

* gnu/packages/groff.scm (groff)[arguments]: Add 'fix-docdir phase.
---
 gnu/packages/groff.scm | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)

Comments

Eric Bavier Jan. 14, 2019, 9:36 p.m. UTC | #1
On Sun, 13 Jan 2019 01:18:50 -0600
ericbavier@centurylink.net wrote:

> From: Eric Bavier <bavier@member.fsf.org>
> 
> * gnu/packages/groff.scm (groff)[arguments]: Add 'fix-docdir phase.
> ---
>  gnu/packages/groff.scm | 7 ++++++-
>  1 file changed, 6 insertions(+), 1 deletion(-)

Pushed in 2df4f7020d2c49110900f786af7700d170c3035c

`~Eric

Patch

diff --git a/gnu/packages/groff.scm b/gnu/packages/groff.scm
index 9bf8662b9f..a8a31337c8 100644
--- a/gnu/packages/groff.scm
+++ b/gnu/packages/groff.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -65,7 +66,11 @@ 
         (add-after 'unpack 'setenv
           (lambda _
             (setenv "GS_GENERATE_UUIDS" "0")
-            #t)))))
+            #t))
+        (add-after 'unpack 'fix-docdir
+          (lambda _         ;see https://savannah.gnu.org/bugs/index.php?55461
+            (substitute* "Makefile.in"
+              (("^docdir =.*") "docdir = @docdir@\n")))))))
    (synopsis "Typesetting from plain text mixed with formatting commands")
    (description
     "Groff is a typesetting package that reads plain text and produces