[bug#33994] gnu: python-pillow: Update to 5.4.0

Message ID 20190106062145.9143-1-kkebreau@posteo.net
State Accepted
Headers show
Series [bug#33994] gnu: python-pillow: Update to 5.4.0 | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Kei Kebreau Jan. 6, 2019, 6:21 a.m. UTC
* gnu/packages/python.scm (python-pillow): Update to 5.4.0.
[arguments]: Add 'patch-ldconfig' phase.
[home-page]: Update URL.
---
 gnu/packages/python.scm | 35 +++++++++++++++++++----------------
 1 file changed, 19 insertions(+), 16 deletions(-)

Comments

Marius Bakke Jan. 11, 2019, 11:22 p.m. UTC | #1
Kei Kebreau <kkebreau@posteo.net> writes:

> * gnu/packages/python.scm (python-pillow): Update to 5.4.0.
> [arguments]: Add 'patch-ldconfig' phase.
> [home-page]: Update URL.

LGTM!  I'd prefer the home page change as a separate commit, but no
strong opinion.
Kei Kebreau Jan. 12, 2019, 9:43 p.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Kei Kebreau <kkebreau@posteo.net> writes:
>
>> * gnu/packages/python.scm (python-pillow): Update to 5.4.0.
>> [arguments]: Add 'patch-ldconfig' phase.
>> [home-page]: Update URL.
>
> LGTM!  I'd prefer the home page change as a separate commit, but no
> strong opinion.

Thanks for reviewing! I've split the patch and pushed.

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ad5c56427..d7d6d1b8b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4151,17 +4151,17 @@  the OleFileIO module from PIL, the Python Image Library.")
 (define-public python-pillow
   (package
     (name "python-pillow")
-    (version "5.2.0")
+    (version "5.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "Pillow" version))
        (sha256
         (base32
-         "1ary9mj2ddllq3lkxgn6aac7qxqiwbcg2pacrl94py58ql9x9czq"))))
+         "0qrkcjszym7ixffg5zphhp8a07w8w11yyc2ylcbdrhwm771z316m"))))
     (build-system python-build-system)
     (native-inputs
-     `(("python-pytest"       ,python-pytest)))
+     `(("python-pytest" ,python-pytest)))
     (inputs
      `(("freetype" ,freetype)
        ("lcms"     ,lcms)
@@ -4173,19 +4173,22 @@  the OleFileIO module from PIL, the Python Image Library.")
     (propagated-inputs
      `(("python-olefile" ,python-olefile)))
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-after
-                   'install 'check-installed
-                   (lambda* (#:key outputs inputs #:allow-other-keys)
-                     (begin
-                       (setenv "HOME" (getcwd))
-                       ;; Make installed package available for running the
-                       ;; tests
-                       (add-installed-pythonpath inputs outputs)
-                       (invoke "python" "selftest.py" "--installed")
-                       (invoke "python" "-m" "pytest" "-vv"))))
-                 (delete 'check))))
-    (home-page "https://pypi.python.org/pypi/Pillow")
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-ldconfig
+           (lambda _
+             (substitute* "setup.py"
+               (("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
+         (delete 'check) ; We must run checks after python-pillow is installed.
+         (add-after 'install 'check-installed
+           (lambda* (#:key outputs inputs #:allow-other-keys)
+             (begin
+               (setenv "HOME" (getcwd))
+               ;; Make installed package available for running the tests.
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" "selftest.py" "--installed")
+               (invoke "python" "-m" "pytest" "-vv")))))))
+    (home-page "https://python-pillow.org")
     (synopsis "Fork of the Python Imaging Library")
     (description
      "The Python Imaging Library adds image processing capabilities to your