[bug#33978] gnu: Add jose.

Message ID 20190104194956.8874-1-manolis837@gmail.com
State Accepted
Commit 4d674b4143b91834554809e5f43edfe117dee79b
Headers show
Series [bug#33978] gnu: Add jose. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Manolis Ragkousis Jan. 4, 2019, 7:49 p.m. UTC
From: Manolis Ragkousis <manolis837@gmail.com>

* gnu/packages/jose.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk          |  1 +
 gnu/packages/jose.scm | 51 +++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 52 insertions(+)
 create mode 100644 gnu/packages/jose.scm

Comments

Manolis Ragkousis Jan. 5, 2019, 3:01 p.m. UTC | #1
Hello everyone,

If nobody has any objections, I will push it to master.

Thank you,
Manolis
Manolis Ragkousis Jan. 7, 2019, 8:18 a.m. UTC | #2
Pushed.

On 1/5/19 5:01 PM, Manolis Ragkousis wrote:
> Hello everyone,
> 
> If nobody has any objections, I will push it to master.
> 
> Thank you,
> Manolis
> 
> 
>

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 6d4159e16..ca1e1bf46 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -244,6 +244,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/javascript.scm			\
   %D%/packages/jemalloc.scm			\
   %D%/packages/jrnl.scm				\
+  %D%/packages/jose.scm				\
   %D%/packages/julia.scm			\
   %D%/packages/kde.scm              \
   %D%/packages/kde-frameworks.scm		\
diff --git a/gnu/packages/jose.scm b/gnu/packages/jose.scm
new file mode 100644
index 000000000..52f1fc80e
--- /dev/null
+++ b/gnu/packages/jose.scm
@@ -0,0 +1,51 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages jose)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix utils)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages web)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages tls))
+
+(define-public jose
+  (package
+    (name "jose")
+    (version "10")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://github.com/latchset/jose/releases/download/v10/jose-"
+                              version ".tar.bz2"))
+              (sha256
+               (base32
+                "0wndxz3jqxfxnv5396da3kc1say7442m7mwk2dw9ykawagxxr72w"))))
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("jansson" ,jansson)
+              ("zlib" ,zlib)
+              ("libcrypto" ,openssl)))
+    (build-system gnu-build-system)
+    (home-page "https://github.com/latchset/jose")
+    (synopsis "Object Signing and Encryption")
+    (description "C-language implementation of Javascript Object Signing and
+Encryption")
+    (license license:asl2.0)))