[bug#33969] gnu: postgresql: Build with openssl support.

Message ID 20190103220538.25708-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#33969] gnu: postgresql: Build with openssl support. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 3, 2019, 10:05 p.m. UTC
* gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to
[inputs]: Add openssl.
---
 gnu/packages/databases.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Danny Milosavljevic Jan. 5, 2019, 11:04 a.m. UTC | #1
LGTM!
Christopher Baines Jan. 13, 2019, 9:55 p.m. UTC | #2
Danny Milosavljevic <dannym@scratchpost.org> writes:

> LGTM!

Great, I've pushed this to staging now.
Christopher Baines Feb. 10, 2019, 10:17 a.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Danny Milosavljevic <dannym@scratchpost.org> writes:
>
>> LGTM!
>
> Great, I've pushed this to staging now.

This patch has somehow got lost, maybe I didn't push it
properly... anyway, I'll push it to again when that branch appears.
Christopher Baines April 28, 2019, 2:27 p.m. UTC | #4
Christopher Baines <mail@cbaines.net> writes:

> * gnu/packages/databases.scm (postgresql)[arguments]: Add --with-openssl to
> [inputs]: Add openssl.
> ---
>  gnu/packages/databases.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index 07c6006c3b..4febd0d915 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -814,7 +814,7 @@ as a drop-in replacement of MySQL.")
>                  "0jv26y3f10svrjxzsgqxg956c86b664azyk2wppzpa5x11pjga38"))))
>      (build-system gnu-build-system)
>      (arguments
> -     `(#:configure-flags '("--with-uuid=e2fs")
> +     `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
>         #:phases
>         (modify-phases %standard-phases
>           (add-before 'configure 'patch-/bin/sh
> @@ -833,6 +833,7 @@ as a drop-in replacement of MySQL.")
>      (inputs
>       `(("readline" ,readline)
>         ("libuuid" ,util-linux)
> +       ("openssl" ,openssl)
>         ("zlib" ,zlib)))
>      (home-page "https://www.postgresql.org/")
>      (synopsis "Powerful object-relational database system")

After sitting for a while in staging, this has now hit master :) So this
bug can be closed.

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 07c6006c3b..4febd0d915 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -814,7 +814,7 @@  as a drop-in replacement of MySQL.")
                 "0jv26y3f10svrjxzsgqxg956c86b664azyk2wppzpa5x11pjga38"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:configure-flags '("--with-uuid=e2fs")
+     `(#:configure-flags '("--with-uuid=e2fs" "--with-openssl")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-/bin/sh
@@ -833,6 +833,7 @@  as a drop-in replacement of MySQL.")
     (inputs
      `(("readline" ,readline)
        ("libuuid" ,util-linux)
+       ("openssl" ,openssl)
        ("zlib" ,zlib)))
     (home-page "https://www.postgresql.org/")
     (synopsis "Powerful object-relational database system")