[bug#33902] gnu: Add wlstream.

Message ID 20181229224304.16864753@mykolab.com
State Accepted
Headers show
Series [bug#33902] gnu: Add wlstream. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling Dec. 29, 2018, 9:43 p.m. UTC
Here's a second version of the patch with a synopsis
and description that's hopefully clearer.

> The description for wlstream is vague and the English unnatural
> ("streams" should be "stream"). I'm not sure what it does and the git
> repo doesn't even provide an explanation. Could you write  a more
> thorough description?

Comments

Ludovic Courtès Jan. 9, 2019, 3:41 p.m. UTC | #1
Hello Rutger,

Rutger Helling <rhelling@mykolab.com> skribis:

> From b38bdecd0dee379f50241092aab2be4b69606209 Mon Sep 17 00:00:00 2001
> From: Rutger Helling <rhelling@mykolab.com>
> Date: Fri, 28 Dec 2018 20:15:22 +0100
> Subject: [PATCH 1/2] gnu: ffmpeg: Add libdrm support.
>
> * gnu/packages/video.scm (ffmpeg): Add libdrm support.

[...]

> From 5d18a851060605deee53c275159a6d37bfc0b007 Mon Sep 17 00:00:00 2001
> From: Rutger Helling <rhelling@mykolab.com>
> Date: Sat, 29 Dec 2018 16:17:59 +0100
> Subject: [PATCH 2/2] gnu: Add wlstream.
>
> * gnu/packages/video.scm (wlstream): New variable.

Both LGTM!

> +(define-public wlstream
> +  (let ((commit "182076a94562b128c3a97ecc53cc68905ea86838")
> +        (revision "1"))
> +    (package
> +     (name "wlstream")
       ^

We usually add an extra space here.  Did you try running
./etc/indent-code.el on your packages?  Or is it too inconvenient?

Thanks,
Ludo’.
Rutger Helling Jan. 10, 2019, 7:57 a.m. UTC | #2
Thanks for the review, pushed with fixed indentation.

I'll make sure to double check with ./etc/indent-code.el from now on.

On Wed, 09 Jan 2019 16:41:31 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

> Hello Rutger,
> 
> Rutger Helling <rhelling@mykolab.com> skribis:
> 
> > From b38bdecd0dee379f50241092aab2be4b69606209 Mon Sep 17 00:00:00
> > 2001 From: Rutger Helling <rhelling@mykolab.com>
> > Date: Fri, 28 Dec 2018 20:15:22 +0100
> > Subject: [PATCH 1/2] gnu: ffmpeg: Add libdrm support.
> >
> > * gnu/packages/video.scm (ffmpeg): Add libdrm support.  
> 
> [...]
> 
> > From 5d18a851060605deee53c275159a6d37bfc0b007 Mon Sep 17 00:00:00
> > 2001 From: Rutger Helling <rhelling@mykolab.com>
> > Date: Sat, 29 Dec 2018 16:17:59 +0100
> > Subject: [PATCH 2/2] gnu: Add wlstream.
> >
> > * gnu/packages/video.scm (wlstream): New variable.  
> 
> Both LGTM!
> 
> > +(define-public wlstream
> > +  (let ((commit "182076a94562b128c3a97ecc53cc68905ea86838")
> > +        (revision "1"))
> > +    (package
> > +     (name "wlstream")  
>        ^
> 
> We usually add an extra space here.  Did you try running
> ./etc/indent-code.el on your packages?  Or is it too inconvenient?
> 
> Thanks,
> Ludo’.
Ludovic Courtès Jan. 10, 2019, 8:54 a.m. UTC | #3
Rutger Helling <rhelling@mykolab.com> skribis:

> Thanks for the review, pushed with fixed indentation.

Thank you.

> I'll make sure to double check with ./etc/indent-code.el from now on.

You shouldn’t lose your hair on it obviously, but if indent-code.el
works well for you, that’d be great.  (We could also add config snippets
for your editor in the repo, if you know what it would take to customize
its indentation facility.)

Ludo’.
Rutger Helling Jan. 11, 2019, 9:25 a.m. UTC | #4
I'm actually using Emacs (with Evil :) ). I think I might have been
using an old version of indent-code.el. I'll see what happens in the
future.

On Thu, 10 Jan 2019 09:54:42 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

> Rutger Helling <rhelling@mykolab.com> skribis:
> 
> > Thanks for the review, pushed with fixed indentation.  
> 
> Thank you.
> 
> > I'll make sure to double check with ./etc/indent-code.el from now
> > on.  
> 
> You shouldn’t lose your hair on it obviously, but if indent-code.el
> works well for you, that’d be great.  (We could also add config
> snippets for your editor in the repo, if you know what it would take
> to customize its indentation facility.)
> 
> Ludo’.

Patch

From 5d18a851060605deee53c275159a6d37bfc0b007 Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Sat, 29 Dec 2018 16:17:59 +0100
Subject: [PATCH 2/2] gnu: Add wlstream.

* gnu/packages/video.scm (wlstream): New variable.
---
 gnu/packages/video.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d7675d5cd..566b0a4e2 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3286,3 +3286,32 @@  transitions, and effects and then export your film to many common formats.")
     (description "dav1d is a new AV1 cross-platform decoder, and focused on
 speed and correctness.")
     (license license:bsd-2)))
+
+(define-public wlstream
+  (let ((commit "182076a94562b128c3a97ecc53cc68905ea86838")
+        (revision "1"))
+    (package
+     (name "wlstream")
+     (version (git-version "0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/atomnuker/wlstream.git")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01qbcgfl3g9kfwn1jf1z9pdj3bvf5lmg71d1vwkcllc2az24bjqp"))))
+     (build-system meson-build-system)
+     (native-inputs `(("libdrm" ,libdrm)
+                      ("pkg-config" ,pkg-config)))
+     (inputs `(("ffmpeg" ,ffmpeg)
+               ("pulseaudio" ,pulseaudio)
+               ("wayland" ,wayland)
+               ("wayland-protocols" ,wayland-protocols)))
+     (home-page "https://github.com/atomnuker/wlstream")
+     (synopsis "Screen capture tool for Wayland sessions")
+     (description "Wlstream is a screen capture tool for recording audio and
+video from a Wayland session.")
+     (license license:lgpl2.1+))))
-- 
2.20.1