[bug#33812,1/2] gnu: extra-cmake-modules: Fix install-path for plugins.

Message ID 20181220141719.19950-1-h.goebel@crazy-compilers.com
State Accepted
Commit 69b608618285d5c2d318feeb93b56c4d5a441ede
Headers show
Series [bug#33812,1/2] gnu: extra-cmake-modules: Fix install-path for plugins. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Hartmut Goebel Dec. 20, 2018, 2:17 p.m. UTC
The respective entry changed for kde-frameworks 5.46.

* gnu/packages/kde-frameworks.scm(krunner)[#phases]<fix-lib-path>:
  Change substitute for QTPLUGINDIR.
---
 gnu/packages/kde-frameworks.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Hartmut Goebel Jan. 4, 2019, 9:27 a.m. UTC | #1
Applied as b824dbec5d331e79a50734fb543bbe064eb7fc17

with trivial changes to the second patch.

Patch

diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 49c986483..8997f0522 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -98,8 +98,10 @@ 
                (("\"lib64\"") "\"lib\"")
                ;; TODO: Base the following on values taken from Qt
                ;; Install plugins into lib/qt5/plugins
-               (("_define_relative\\(QTPLUGINDIR LIBDIR \"plugins\"")
-                "_define_relative(QTPLUGINDIR LIBDIR \"qt5/plugins\"")
+               ;; TODO: Check if this is okay for Android, too
+               ;; (see comment in KDEInstallDirs.cmake)
+               (("_define_relative\\(QTPLUGINDIR \"\\$\\{_pluginsDirParent}\" \"plugins\"")
+                "_define_relative(QTPLUGINDIR \"${_pluginsDirParent}\" \"qt5/plugins\"")
                ;; Install imports into lib/qt5/imports
                (("_define_relative\\(QTQUICKIMPORTSDIR QTPLUGINDIR \"imports\"")
                 "_define_relative(QTQUICKIMPORTSDIR LIBDIR \"qt5/imports\"")