[bug#33725,v2] gnu: llvm-rtti: Remove it.

Message ID 20181213132832.24877-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#33725,v2] gnu: llvm-rtti: Remove it. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Dec. 13, 2018, 1:28 p.m. UTC
This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.

It sounds from the comment that this can hopefully be removed now.

* gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
* gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
llvm-without-rtti.
---
 gnu/packages/gl.scm   |  3 +--
 gnu/packages/llvm.scm | 20 --------------------
 2 files changed, 1 insertion(+), 22 deletions(-)

Comments

Leo Famulari Dec. 13, 2018, 8:27 p.m. UTC | #1
On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
> 
> It sounds from the comment that this can hopefully be removed now.
> 
> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
> llvm-without-rtti.

Thanks! If the change doesn't trigger any rebuilds (that is, if the
package is really unused), please push!

Ideally, the commit message will say which commit made this package
unnecessary.
Christopher Baines Dec. 14, 2018, 4:22 p.m. UTC | #2
Leo Famulari <leo@famulari.name> writes:

> On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
>> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>>
>> It sounds from the comment that this can hopefully be removed now.
>>
>> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
>> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
>> llvm-without-rtti.
>
> Thanks! If the change doesn't trigger any rebuilds (that is, if the
> package is really unused), please push!
>
> Ideally, the commit message will say which commit made this package
> unnecessary.

So, my understanding of this is that this change was made to prevent
some rebuilds a while ago. It does trigger quite a few rebuilds (1120),
so it'll need pushing to staging/core-updates.

I'll test some of these packages locally, and then probably push it to
core-updates, as there's some other stuff on staging I'd like to see
merged to master soonish.
Christopher Baines Dec. 15, 2018, 8:46 p.m. UTC | #3
Christopher Baines <mail@cbaines.net> writes:

> Leo Famulari <leo@famulari.name> writes:
>
>> On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
>>> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>>>
>>> It sounds from the comment that this can hopefully be removed now.
>>>
>>> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
>>> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
>>> llvm-without-rtti.
>>
>> Thanks! If the change doesn't trigger any rebuilds (that is, if the
>> package is really unused), please push!
>>
>> Ideally, the commit message will say which commit made this package
>> unnecessary.
>
> So, my understanding of this is that this change was made to prevent
> some rebuilds a while ago. It does trigger quite a few rebuilds (1120),
> so it'll need pushing to staging/core-updates.
>
> I'll test some of these packages locally, and then probably push it to
> core-updates, as there's some other stuff on staging I'd like to see
> merged to master soonish.

I've tweaked the commit message, and tested this on top of core-updates
now. With a tweak to fix the build for python2-(minimal), I've
successfully built mesa and a few of it's dependnecies. So I've now
pushed to core-updates.
Marius Bakke Dec. 21, 2018, 9:17 p.m. UTC | #4
Christopher Baines <mail@cbaines.net> writes:

> Leo Famulari <leo@famulari.name> writes:
>
>> On Thu, Dec 13, 2018 at 02:28:32PM +0100, Christopher Baines wrote:
>>> This reverts commit f8cba3ff4fc6aed0c539700aa47b6e8f4c25c34d.
>>>
>>> It sounds from the comment that this can hopefully be removed now.
>>>
>>> * gnu/packages/llvm.scm (llvm-without-rtti): Remove it.
>>> * gnu/packages/gl.scm (mesa)[inputs]: Switch to using llvm rather than
>>> llvm-without-rtti.
>>
>> Thanks! If the change doesn't trigger any rebuilds (that is, if the
>> package is really unused), please push!
>>
>> Ideally, the commit message will say which commit made this package
>> unnecessary.
>
> So, my understanding of this is that this change was made to prevent
> some rebuilds a while ago. It does trigger quite a few rebuilds (1120),
> so it'll need pushing to staging/core-updates.
>
> I'll test some of these packages locally, and then probably push it to
> core-updates, as there's some other stuff on staging I'd like to see
> merged to master soonish.

Good news!  This commit is already on 'staging' and should be merged
soonish: 

https://git.savannah.gnu.org/cgit/guix.git/commit/?id=730a4728cc38799f9683bde5a0711ab10d42a9f8

:-)

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index d7c112928f..5313a74e5c 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -255,8 +255,7 @@  also known as DXTn or DXTC) for Mesa.")
         ("libxvmc" ,libxvmc)
         ,@(match (%current-system)
             ((or "x86_64-linux" "i686-linux")
-             ;; FIXME: Change to 'llvm' in the next rebuild cycle.
-             `(("llvm" ,llvm-without-rtti)))
+             `(("llvm" ,llvm)))
             (_
              `()))
         ("makedepend" ,makedepend)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 7eb785c364..ec79bcc95c 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -110,26 +110,6 @@  of programming tools as well as libraries with equivalent functionality.")
        (base32
         "08p27wv1pr9ql2zc3f3qkkymci46q7myvh8r5ijippnbwr2gihcb"))))))
 
-;; FIXME: This package is here to prevent many rebuilds on x86_64 and i686
-;; from commit fc9dbf41311d99d0fd8befc789ea7c0e35911890.  Update users of
-;; this in the next rebuild cycle.
-(define-public llvm-without-rtti
-  (package
-    (inherit llvm)
-    (arguments
-     `(#:configure-flags '("-DCMAKE_SKIP_BUILD_RPATH=FALSE"
-                           "-DCMAKE_BUILD_WITH_INSTALL_RPATH=FALSE"
-                           "-DBUILD_SHARED_LIBS:BOOL=TRUE"
-                           "-DLLVM_ENABLE_FFI:BOOL=TRUE"
-                           "-DLLVM_INSTALL_UTILS=ON")
-       #:build-type "Release"
-       #:phases (modify-phases %standard-phases
-                  (add-before 'build 'shared-lib-workaround
-                    (lambda _
-                      (setenv "LD_LIBRARY_PATH"
-                              (string-append (getcwd) "/lib"))
-                      #t)))))))
-
 (define* (clang-runtime-from-llvm llvm hash
                                   #:optional (patches '()))
   (package