[bug#33716,staging] gnu: mesa: Update to 18.3.1.

Message ID 20181212113133.0250a68f@mykolab.com
State Accepted
Headers show
Series [bug#33716,staging] gnu: mesa: Update to 18.3.1. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling Dec. 12, 2018, 10:31 a.m. UTC
Hey Guix,

Here's a Mesa update for the just released 18.3.1 version. Not sure
whether or not I'm too late for the staging branch. If I am this can
wait until the next staging branch.

Two things to note:
* While Mesa 18.3.x still builds with LLVM 6 the upcoming 19.0.x series
  doesn't anymore. For that and performance reasons I decided to add a
  llvm@7.0.0 package for Mesa. I don't know enough about the LLVM stack
  to upgrade it entirely, so this is kind of a workaround.
* Since Mesa 18.3 works with Python 3 I've replaced the Python 2
  dependencies with Python 3 ones.

Comments

Marius Bakke Dec. 12, 2018, 9:02 p.m. UTC | #1
Rutger Helling <rhelling@mykolab.com> writes:

> Hey Guix,
>
> Here's a Mesa update for the just released 18.3.1 version. Not sure
> whether or not I'm too late for the staging branch. If I am this can
> wait until the next staging branch.

Thanks!  I've pushed this patch on your behalf and started the 'staging'
jobset on Hydra, with a small change...

> Two things to note:
> * While Mesa 18.3.x still builds with LLVM 6 the upcoming 19.0.x series
>   doesn't anymore. For that and performance reasons I decided to add a
>   llvm@7.0.0 package for Mesa. I don't know enough about the LLVM stack
>   to upgrade it entirely, so this is kind of a workaround.

LLVM 7 is a heavy dependency, so I opted to drop it since it is not
required.  Feel free to add the LLVM@7 variant on 'master' in the mean
time -- it would be good to make it the default in the next staging
cycle.  Did you try upgrading Clang as well?

> * Since Mesa 18.3 works with Python 3 I've replaced the Python 2
>   dependencies with Python 3 ones.

Great, thanks for keeping up with Mesa development!
Rutger Helling Dec. 13, 2018, 10:51 a.m. UTC | #2
Thanks for pushing! Unfortunately I couldn't get Clang to upgrade to
7.0.0. I've added a llvm@7.0.0 variant to master along with comments
about Mesa and Clang.

On Wed, 12 Dec 2018 22:02:36 +0100
Marius Bakke <mbakke@fastmail.com> wrote:

> Rutger Helling <rhelling@mykolab.com> writes:
> 
> > Hey Guix,
> >
> > Here's a Mesa update for the just released 18.3.1 version. Not sure
> > whether or not I'm too late for the staging branch. If I am this can
> > wait until the next staging branch.  
> 
> Thanks!  I've pushed this patch on your behalf and started the
> 'staging' jobset on Hydra, with a small change...
> 
> > Two things to note:
> > * While Mesa 18.3.x still builds with LLVM 6 the upcoming 19.0.x
> > series doesn't anymore. For that and performance reasons I decided
> > to add a llvm@7.0.0 package for Mesa. I don't know enough about the
> > LLVM stack to upgrade it entirely, so this is kind of a
> > workaround.  
> 
> LLVM 7 is a heavy dependency, so I opted to drop it since it is not
> required.  Feel free to add the LLVM@7 variant on 'master' in the mean
> time -- it would be good to make it the default in the next staging
> cycle.  Did you try upgrading Clang as well?
> 
> > * Since Mesa 18.3 works with Python 3 I've replaced the Python 2
> >   dependencies with Python 3 ones.  
> 
> Great, thanks for keeping up with Mesa development!

Patch

From 05c7ad44062de775ec4b1443b809a417f9bd37a8 Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Wed, 12 Dec 2018 08:42:55 +0100
Subject: [PATCH 2/2] gnu: mesa: Update to 18.3.1.

* gnu/packages/gl.scm (mesa): Update to 18.3.1.
[inputs]: Use llvm@7.0.0 instead of llvm.
[native-inputs]: Use python instead of python-2. Use python-mako instead of
python2-mako.
---
 gnu/packages/gl.scm | 10 +++++-----
 1 file changed, 5 insertions(+), 5 deletions(-)

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1bf53bcbb..8d4f14fb4 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -221,7 +221,7 @@  also known as DXTn or DXTC) for Mesa.")
 (define-public mesa
   (package
     (name "mesa")
-    (version "18.2.6")
+    (version "18.3.1")
     (source
       (origin
         (method url-fetch)
@@ -233,7 +233,7 @@  also known as DXTn or DXTC) for Mesa.")
                                   version "/mesa-" version ".tar.xz")))
         (sha256
          (base32
-          "04nwxykmc80gicmal0zkk8is34rmbqawmfckirqhrps9h97zmfly"))
+          "0qyw9dj2p9n91qzc4ylck2an7ibssjvzi2bjcpv2ajk851yq47sv"))
         (patches
          (search-patches "mesa-skip-disk-cache-test.patch"))))
     (build-system gnu-build-system)
@@ -257,7 +257,7 @@  also known as DXTn or DXTC) for Mesa.")
         ("libxvmc" ,libxvmc)
         ,@(match (%current-system)
             ((or "x86_64-linux" "i686-linux")
-             `(("llvm" ,llvm)))
+             `(("llvm" ,llvm-7.0.0)))
             (_
              `()))
         ("makedepend" ,makedepend)
@@ -265,8 +265,8 @@  also known as DXTn or DXTC) for Mesa.")
         ("wayland-protocols" ,wayland-protocols)))
     (native-inputs
       `(("pkg-config" ,pkg-config)
-        ("python" ,python-2)
-        ("python2-mako" ,python2-mako)
+        ("python" ,python)
+        ("python-mako" ,python-mako)
         ("which" ,(@ (gnu packages base) which))))
     (arguments
      `(#:configure-flags
-- 
2.20.0