[bug#33710] gnu: Add dav1d.

Message ID 20181211193447.11765-1-efraim@flashner.co.il
State Accepted
Headers show
Series [bug#33710] gnu: Add dav1d. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Efraim Flashner Dec. 11, 2018, 7:34 p.m. UTC
* gnu/packages/video.scm (dav1d): New variable.
---
 gnu/packages/video.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Eric Bavier Dec. 12, 2018, 1:21 a.m. UTC | #1
On Tue, 11 Dec 2018 21:34:47 +0200
Efraim Flashner <efraim@flashner.co.il> wrote:

> * gnu/packages/video.scm (dav1d): New variable.
> ---
>  gnu/packages/video.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
> 
> diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> index fc6caf3ff..67c0cccaa 100644
> --- a/gnu/packages/video.scm
> +++ b/gnu/packages/video.scm
> @@ -3264,3 +3264,23 @@ API.  It includes bindings for Python, Ruby, and other languages.")
>  helps you create the film you have always dreamed of.  Easily add sub-titles,
>  transitions, and effects and then export your film to many common formats.")
>      (license license:gpl3+)))
> +
> +(define-public dav1d
> +  (package
> +    (name "dav1d")
> +    (version "0.1.0")
> +    (source
> +      (origin
> +        (method url-fetch)
> +        (uri (string-append "https://downloads.videolan.org/pub/videolan/"
> +                            "dav1d/" version "/dav1d-" version ".tar.xz"))
> +        (sha256
> +         (base32
> +          "0dw0liday8cbyrirhm6bgzhxg4cdy66nspfkdlq338gdsfqcvrsc"))))
> +    (build-system meson-build-system)
> +    (native-inputs `(("nasm" ,nasm)))
> +    (home-page "https://code.videolan.org/videolan/dav1d")
> +    (synopsis "AV1 decoder")
> +    (description "dav1d is a new AV1 cross-platform decoder, open-source, and

We do not need to mention the "open-source" nature of the software.

> +focused on speed and correctness.")
> +    (license license:bsd-2)))
Efraim Flashner Dec. 12, 2018, 7:25 a.m. UTC | #2
On Tue, Dec 11, 2018 at 07:21:24PM -0600, Eric Bavier wrote:
> On Tue, 11 Dec 2018 21:34:47 +0200
> Efraim Flashner <efraim@flashner.co.il> wrote:
> 
> > * gnu/packages/video.scm (dav1d): New variable.
> > ---
> >  gnu/packages/video.scm | 20 ++++++++++++++++++++
> >  1 file changed, 20 insertions(+)
> > 
> > diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
> > index fc6caf3ff..67c0cccaa 100644
> > --- a/gnu/packages/video.scm
> > +++ b/gnu/packages/video.scm
> > @@ -3264,3 +3264,23 @@ API.  It includes bindings for Python, Ruby, and other languages.")
> >  helps you create the film you have always dreamed of.  Easily add sub-titles,
> >  transitions, and effects and then export your film to many common formats.")
> >      (license license:gpl3+)))
> > +
> > +(define-public dav1d
> > +  (package
> > +    (name "dav1d")
> > +    (version "0.1.0")
> > +    (source
> > +      (origin
> > +        (method url-fetch)
> > +        (uri (string-append "https://downloads.videolan.org/pub/videolan/"
> > +                            "dav1d/" version "/dav1d-" version ".tar.xz"))
> > +        (sha256
> > +         (base32
> > +          "0dw0liday8cbyrirhm6bgzhxg4cdy66nspfkdlq338gdsfqcvrsc"))))
> > +    (build-system meson-build-system)
> > +    (native-inputs `(("nasm" ,nasm)))
> > +    (home-page "https://code.videolan.org/videolan/dav1d")
> > +    (synopsis "AV1 decoder")
> > +    (description "dav1d is a new AV1 cross-platform decoder, open-source, and
> 
> We do not need to mention the "open-source" nature of the software.
> 

Not sure how I missed that one

> > +focused on speed and correctness.")
> > +    (license license:bsd-2)))
>

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index fc6caf3ff..67c0cccaa 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3264,3 +3264,23 @@  API.  It includes bindings for Python, Ruby, and other languages.")
 helps you create the film you have always dreamed of.  Easily add sub-titles,
 transitions, and effects and then export your film to many common formats.")
     (license license:gpl3+)))
+
+(define-public dav1d
+  (package
+    (name "dav1d")
+    (version "0.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://downloads.videolan.org/pub/videolan/"
+                            "dav1d/" version "/dav1d-" version ".tar.xz"))
+        (sha256
+         (base32
+          "0dw0liday8cbyrirhm6bgzhxg4cdy66nspfkdlq338gdsfqcvrsc"))))
+    (build-system meson-build-system)
+    (native-inputs `(("nasm" ,nasm)))
+    (home-page "https://code.videolan.org/videolan/dav1d")
+    (synopsis "AV1 decoder")
+    (description "dav1d is a new AV1 cross-platform decoder, open-source, and
+focused on speed and correctness.")
+    (license license:bsd-2)))