[bug#33702,2/7] gnu: Add python-serpent.

Message ID 20181211070607.20548-2-mail@cbaines.net
State Accepted
Commit 053f3d48578e10e8e4be348f3ad6de539cfa2455
Headers show
Series [bug#33702,1/7] gnu: Add python-pytest-sugar. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Dec. 11, 2018, 7:06 a.m. UTC
This is required for python-pyro4, which is needed to update python-amqp and
python-kombu.

* gnu/packages/python.scm (python-serpent): New variable.
---
 gnu/packages/python.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Patch

diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 23b980ec32..e973fd8a5d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -908,6 +908,29 @@  version identifier.")
 (define-public python2-semantic-version
   (package-with-python2 python-semantic-version))
 
+(define-public python-serpent
+  (package
+    (name "python-serpent")
+    (version "1.27")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "serpent" version))
+       (sha256
+        (base32
+         "04p9dsrm5pv8vhk3flvih55kgvlzpi38hlaykdiakddmgwqw93bg"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/irmen/Serpent")
+    (synopsis "Serializer for literal Python expressions")
+    (description
+     "Serpent provides ast.literal_eval() compatible object tree
+serialization.  It serializes an object tree into bytes (utf-8 encoded string)
+that can be decoded and then passed as-is to ast.literal_eval() to rebuild it
+as the original object tree.  As such it is safe to send serpent data to other
+machines over the network for instance (because only safe literals are
+encoded).")
+    (license license:expat)))
+
 (define-public python-setuptools
   (package
     (name "python-setuptools")