[bug#33562] gnu: Add librepcb.

Message ID 20181201133032.14920-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#33562] gnu: Add librepcb. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Arun Isaac Dec. 1, 2018, 1:30 p.m. UTC
* gnu/packages/engineering.scm (librepcb): New variable.
---
 gnu/packages/engineering.scm | 52 ++++++++++++++++++++++++++++++++++++
 1 file changed, 52 insertions(+)

Comments

Leo Famulari Dec. 12, 2018, 2:15 a.m. UTC | #1
On Sat, Dec 01, 2018 at 07:00:32PM +0530, Arun Isaac wrote:
> * gnu/packages/engineering.scm (librepcb): New variable.

Cool, thanks!

> +    (description "LibrePCB is Electronic Design Automation (EDA) software to

How about some texinfo markup?

@dfn{Electronic Design Automation} (EDA)
Arun Isaac Dec. 12, 2018, 7:40 p.m. UTC | #2
>> +    (description "LibrePCB is Electronic Design Automation (EDA) software to
>
> How about some texinfo markup?
>
> @dfn{Electronic Design Automation} (EDA)

Thanks for the review! Will that be the only change? Can I push to
master with that change?
Leo Famulari Dec. 12, 2018, 11:15 p.m. UTC | #3
On Thu, Dec 13, 2018 at 01:10:31AM +0530, Arun Isaac wrote:
> Thanks for the review! Will that be the only change? Can I push to
> master with that change?

That's the only thing I noticed. Please push according to your judgement
:)
Arun Isaac Dec. 13, 2018, 1:02 p.m. UTC | #4
Pushed to master, thanks!

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 008035649..4b9c76fd5 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;; Copyright © 2018 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1846,3 +1847,54 @@  The S letter indicates SPICE.  The purpose of the Qucs-S subproject is to use
 free SPICE circuit simulation kernels with the Qucs GUI.  It provides the
 simulator backends @code{Qucsator}, @code{ngspice} and @code{Xyce}.")
     (license license:gpl2+)))
+
+(define-public librepcb
+  (package
+    (name "librepcb")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://download.librepcb.org/releases/0.1.0/librepcb-"
+                           version "-source.zip"))
+       (sha256
+        (base32
+         "0affvwwgs1j2wx6bb3zfa2jbfxpckklr8cka2nkswca0p82wd3dv"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("qtbase" ,qtbase)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("qttools" ,qttools) ; for lrelease
+       ("unzip" ,unzip)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (mkdir-p "build")
+             (chdir "build")
+             (let ((lrelease (string-append (assoc-ref inputs "qttools")
+                                            "/bin/lrelease"))
+                   (out (assoc-ref outputs "out")))
+               (invoke "qmake"
+                       (string-append "QMAKE_LRELEASE=" lrelease)
+                       (string-append "PREFIX=" out)
+                       "../librepcb.pro")))))))
+    (home-page "https://librepcb.org/")
+    (synopsis "Electronic Design Automation tool")
+    (description "LibrePCB is Electronic Design Automation (EDA) software to
+develop printed circuit boards.  It features human readable file formats and
+complete project management with library, schematic and board editors.")
+    (license (list license:gpl3+
+                   license:boost1.0 ; libs/clipper,
+                                    ; libs/optional/tests/catch.hpp,
+                                    ; libs/sexpresso/tests/catch.hpp
+                   license:expat ; libs/delaunay-triangulation,
+                                 ; libs/parseagle, libs/type_safe
+                   license:asl2.0 ; libs/fontobene, libs/googletest,
+                                  ; libs/parseagle
+                   license:isc ; libs/hoedown
+                   license:cc0 ; libs/optional, libs/sexpresso
+                   license:bsd-2 ; libs/optional/tests/catch.hpp
+                   license:lgpl2.1+)))) ; libs/quazip