[bug#33546,1/2] gnu: sassc: Fix build.

Message ID 20181129004818.187af6cd@alma-ubu
State Accepted
Headers show
Series Fix arc-theme | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Björn Höfling Nov. 28, 2018, 11:48 p.m. UTC
From: Ricardo Wurmus <rekado@elephly.net>
Date: Sun, 5 Aug 2018 13:03:09 +0200


* gnu/packages/web.scm (sassc)[arguments]: Delete bootstrap phase; let
phase end on boolean.
---
 gnu/packages/web.scm | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

       (synopsis "CSS pre-processor")

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 7f9574827..2e3647ddc 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -1281,12 +1281,14 @@  minimum to provide high performance operation.")
          #:tests? #f
          #:phases
          (modify-phases %standard-phases
+           (delete 'bootstrap)
            (delete 'configure)
            (add-after 'unpack 'unpack-libsass-and-set-path
              (lambda* (#:key inputs #:allow-other-keys)
                (invoke "tar" "xvf" (assoc-ref inputs "libsass"))
                (setenv "SASS_LIBSASS_PATH"
-                       (string-append (getcwd)
"/libsass-" ,version)))))))
+                       (string-append (getcwd) "/libsass-" ,version))
+               #t)))))
       (inputs
        `(("libsass" ,libsass)))