[bug#33484] gnu: rocksdb: Update to 5.17.2

Message ID 20181124064849.31101-1-brettg@posteo.net
State Accepted
Headers show
Series [bug#33484] gnu: rocksdb: Update to 5.17.2 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Brett Gilio Nov. 24, 2018, 6:48 a.m. UTC
---
 gnu/packages/databases.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Marius Bakke Nov. 29, 2018, 5:30 p.m. UTC | #1
Hello Brett,

Thanks for this patch!

Brett Gilio <brettg@posteo.net> writes:

> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
> index ac1b23a32..72f316c05 100644
> --- a/gnu/packages/databases.scm
> +++ b/gnu/packages/databases.scm
> @@ -973,7 +973,7 @@ types are supported, as is encryption.")
>  (define-public rocksdb
>    (package
>      (name "rocksdb")
> -    (version "5.12.4")
> +    (version "5.17.2")
>      (source (origin
>                (method url-fetch)
>                (uri (string-append "https://github.com/facebook/rocksdb"
> @@ -981,7 +981,7 @@ types are supported, as is encryption.")
>                (file-name (string-append name "-" version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1jcwgsjhk4hdfr2wf549blkgb89vwcdb5i2ahhqs6zf3mm20i3bf"))
> +                "0a1dbjlyc5388rs7syyy4hxvz8x14a136wj81v4i1a2hhs2ha7qh"))

This package was changed on the 'core-updates' branch to use a git
checkout instead of a tarball.  Can you adjust this patch accordingly?

Thanks in advance!
Brett Gilio Dec. 5, 2019, 12:41 a.m. UTC | #2
Marius Bakke <mbakke@fastmail.com> writes:

> Hello Brett,
>
> Thanks for this patch!
>
> Brett Gilio <brettg@posteo.net> writes:
>
>> diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
>> index ac1b23a32..72f316c05 100644
>> --- a/gnu/packages/databases.scm
>> +++ b/gnu/packages/databases.scm
>> @@ -973,7 +973,7 @@ types are supported, as is encryption.")
>>  (define-public rocksdb
>>    (package
>>      (name "rocksdb")
>> -    (version "5.12.4")
>> +    (version "5.17.2")
>>      (source (origin
>>                (method url-fetch)
>>                (uri (string-append "https://github.com/facebook/rocksdb"
>> @@ -981,7 +981,7 @@ types are supported, as is encryption.")
>>                (file-name (string-append name "-" version ".tar.gz"))
>>                (sha256
>>                 (base32
>> -                "1jcwgsjhk4hdfr2wf549blkgb89vwcdb5i2ahhqs6zf3mm20i3bf"))
>> +                "0a1dbjlyc5388rs7syyy4hxvz8x14a136wj81v4i1a2hhs2ha7qh"))
>
> This package was changed on the 'core-updates' branch to use a git
> checkout instead of a tarball.  Can you adjust this patch accordingly?
>
> Thanks in advance!
>

This is a historical bug report and is no longer relevant. It can be
closed.
Efraim Flashner Dec. 5, 2019, 8:36 a.m. UTC | #3
close bug

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index ac1b23a32..72f316c05 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -973,7 +973,7 @@  types are supported, as is encryption.")
 (define-public rocksdb
   (package
     (name "rocksdb")
-    (version "5.12.4")
+    (version "5.17.2")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/facebook/rocksdb"
@@ -981,7 +981,7 @@  types are supported, as is encryption.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1jcwgsjhk4hdfr2wf549blkgb89vwcdb5i2ahhqs6zf3mm20i3bf"))
+                "0a1dbjlyc5388rs7syyy4hxvz8x14a136wj81v4i1a2hhs2ha7qh"))
               (modules '((guix build utils)))
               (snippet
                '(begin