[bug#33437,10/10] gnu: ocaml-lambda-term: Use dune-build-system.

Message ID 20181119222821.16789-10-julien@lepiller.eu
State Accepted
Commit 34d5314e9c826b1f602f9aaa8d707ca594736aaf
Headers show
Series [bug#33437,01/10] build: Add dune-build-system. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Julien Lepiller Nov. 19, 2018, 10:28 p.m. UTC
* gnu/packages/ocaml.scm (ocaml-lambda-term): Use dune-build-system.
---
 gnu/packages/ocaml.scm | 17 ++---------------
 1 file changed, 2 insertions(+), 15 deletions(-)

Comments

Ludovic Courtès Nov. 24, 2018, 9:18 p.m. UTC | #1
The remaining patches LGTM.  Perhaps it would be best to commit all this
to ‘core-updates’, to avoid gratuitous rebuilds of all the OCaml
packages now that we’re close to merging ‘core-updates’.

Thank you!

Ludo’.

Patch

diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 896f3840a..7ed5c1951 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4481,23 +4481,10 @@  connect an engine to your inputs and rendering functions to get an editor.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "1hy5ryagqclgdm9lzh1qil5mrynlypv7mn6qm858hdcnmz9zzn0l"))))
-    (build-system ocaml-build-system)
+    (build-system dune-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'configure)
-         (replace 'build
-           (lambda _
-             (invoke "dune" "build" "@install" "--profile" "release")
-             #t))
-         (replace 'install
-           (lambda* (#:key outputs #:allow-other-keys)
-             (invoke "dune" "install"
-                     "--prefix" (assoc-ref outputs "out"))
-             #t)))
+     `(#:build-flags (list "--profile" "release")
        #:tests? #f))
-    (native-inputs
-     `(("dune" ,dune)))
     (propagated-inputs
      `(("lwt" ,ocaml-lwt)
        ("lwt-log" ,ocaml-lwt-log)