[bug#33406] gnu: package: Add guile-mastodon.

Message ID 20181116104826.18033-1-contact@parouby.fr
State Accepted
Headers show
Series [bug#33406] gnu: package: Add guile-mastodon. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

parouby Nov. 16, 2018, 10:48 a.m. UTC
* gnu/packages/guile.scm (guile-mastodon): New variable.
---
 gnu/packages/guile.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Mathieu Othacehe Nov. 16, 2018, 2:25 p.m. UTC | #1
Hello Pierre-Antoine,

Good to see more Guile bindings :)

> +    (propagated-inputs
> +     `(("guile" ,guile-2.2)

I'm not sure it makes sense for guile to be a propagated-input here, why
not an input?

Thanks,

Mathieu
parouby Nov. 19, 2018, 3 p.m. UTC | #2
Hello Mathieu,

On 16/11/2018 15:25, Mathieu Othacehe wrote:
> I'm not sure it makes sense for guile to be a propagated-input here, why
> not an input?

Yes, it's true, and I think gnutls will by in input too.
I will modify and resend patch soon.

PA

Patch

diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index f95641ab1..9f1492e1c 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -2362,4 +2362,32 @@  Scheme by using Guile’s foreign function interface.")
       (home-page "https://gitlab.com/mothacehe/guile-newt")
       (license license:gpl3+))))
 
+(define-public guile-mastodon
+  (package
+    (name "guile-mastodon")
+    (version "0.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://framagit.org/prouby/guile-mastodon.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1vblf3d1bbwna3l09p2ap5y8ycvl549bz6whgk78imyfmn28ygry"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     `(("guile" ,guile-2.2)
+       ("guile-json" ,guile-json)
+       ("gnutls" ,gnutls)))
+    (home-page "https://framagit.org/prouby/guile-mastodon")
+    (synopsis "Guile Mastodon REST API module")
+    (description "This package provides Guile module for Mastodon REST API
+@url{https://docs.joinmastodon.org/api/}.")
+    (license license:gpl3+)))
+
 ;;; guile.scm ends here