[bug#33390,1/4] qtwebkit: Fix pri install directory.

Message ID 20181115041715.15993-2-ericbavier@centurylink.net
State Accepted
Headers show
Series Add OpenShot | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Eric Bavier Nov. 15, 2018, 4:17 a.m. UTC
From: Eric Bavier <bavier@member.fsf.org>

This lets qmake find qtwebkit components, allowing packages like python-pyqt
to find qtwebkit and enable support.

* gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
to #:configure-flags.  Link with "--no-keep-memory".
---
 gnu/packages/qt.scm | 11 ++++++++++-
 1 file changed, 10 insertions(+), 1 deletion(-)

Comments

Christopher Baines Nov. 19, 2018, 10:22 p.m. UTC | #1
ericbavier@centurylink.net writes:

> From: Eric Bavier <bavier@member.fsf.org>
>
> This lets qmake find qtwebkit components, allowing packages like python-pyqt
> to find qtwebkit and enable support.
>
> * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
> to #:configure-flags.  Link with "--no-keep-memory".
> ---
>  gnu/packages/qt.scm | 11 ++++++++++-
>  1 file changed, 10 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> index d48769982..36f8aef69 100644
> --- a/gnu/packages/qt.scm
> +++ b/gnu/packages/qt.scm
> @@ -10,6 +10,7 @@
>  ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
>  ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
>  ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
> +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
>         #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
>                                 "-DPORT=Qt"
>                                 "-DUSE_LIBHYPHEN=OFF"
> -                               "-DUSE_SYSTEM_MALLOC=ON")))
> +                               "-DUSE_SYSTEM_MALLOC=ON"
> +                               ;; XXX: relative dir installs to build dir?
> +                               (string-append "-DECM_MKSPECS_INSTALL_DIR="
> +                                              %output "/lib/qt5/mkspecs/modules")
> +                               ;; Sacrifice a little speed in order to link
> +                               ;; libraries and test executables in a
> +                               ;; reasonable amount of memory.
> +                               "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
> +                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
>      (home-page "https://www.webkit.org")
>      (synopsis "Web browser engine and classes to render and interact with web
>  content")

I've tested this, and this fixed the qtwebkit build for me, which
currently doesn't work on master. So I'm all for merging it.
Eric Bavier Nov. 20, 2018, 4:22 a.m. UTC | #2
Hi Christopher,

On Mon, 19 Nov 2018 22:22:58 +0000
Christopher Baines <mail@cbaines.net> wrote:

> ericbavier@centurylink.net writes:
> 
> > From: Eric Bavier <bavier@member.fsf.org>
> >
> > This lets qmake find qtwebkit components, allowing packages like python-pyqt
> > to find qtwebkit and enable support.
> >
> > * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
> > to #:configure-flags.  Link with "--no-keep-memory".
> > ---
> >  gnu/packages/qt.scm | 11 ++++++++++-
> >  1 file changed, 10 insertions(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> > index d48769982..36f8aef69 100644
> > --- a/gnu/packages/qt.scm
> > +++ b/gnu/packages/qt.scm
> > @@ -10,6 +10,7 @@
> >  ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> >  ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> >  ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
> > +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> >  ;;;
> >  ;;; This file is part of GNU Guix.
> >  ;;;
> > @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
> >         #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
> >                                 "-DPORT=Qt"
> >                                 "-DUSE_LIBHYPHEN=OFF"
> > -                               "-DUSE_SYSTEM_MALLOC=ON")))
> > +                               "-DUSE_SYSTEM_MALLOC=ON"
> > +                               ;; XXX: relative dir installs to build dir?
> > +                               (string-append "-DECM_MKSPECS_INSTALL_DIR="
> > +                                              %output "/lib/qt5/mkspecs/modules")
> > +                               ;; Sacrifice a little speed in order to link
> > +                               ;; libraries and test executables in a
> > +                               ;; reasonable amount of memory.
> > +                               "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
> > +                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
> >      (home-page "https://www.webkit.org")
> >      (synopsis "Web browser engine and classes to render and interact with web
> >  content")  
> 
> I've tested this, and this fixed the qtwebkit build for me, which
> currently doesn't work on master. So I'm all for merging it.

Thanks for testing it.  I assume it was the linker flags that fixed the
build on your machine?  For clarity, I suppose that change should be
moved to a separate patch.  WDYT?

`~Eric
Christopher Baines Nov. 20, 2018, 5:48 p.m. UTC | #3
Eric Bavier <ericbavier@centurylink.net> writes:

>> > From: Eric Bavier <bavier@member.fsf.org>
>> >
>> > This lets qmake find qtwebkit components, allowing packages like python-pyqt
>> > to find qtwebkit and enable support.
>> >
>> > * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
>> > to #:configure-flags.  Link with "--no-keep-memory".
>> > ---
>> >  gnu/packages/qt.scm | 11 ++++++++++-
>> >  1 file changed, 10 insertions(+), 1 deletion(-)
>> >
>> > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
>> > index d48769982..36f8aef69 100644
>> > --- a/gnu/packages/qt.scm
>> > +++ b/gnu/packages/qt.scm
>> > @@ -10,6 +10,7 @@
>> >  ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
>> >  ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
>> >  ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
>> > +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
>> >  ;;;
>> >  ;;; This file is part of GNU Guix.
>> >  ;;;
>> > @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
>> >         #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
>> >                                 "-DPORT=Qt"
>> >                                 "-DUSE_LIBHYPHEN=OFF"
>> > -                               "-DUSE_SYSTEM_MALLOC=ON")))
>> > +                               "-DUSE_SYSTEM_MALLOC=ON"
>> > +                               ;; XXX: relative dir installs to build dir?
>> > +                               (string-append "-DECM_MKSPECS_INSTALL_DIR="
>> > +                                              %output "/lib/qt5/mkspecs/modules")
>> > +                               ;; Sacrifice a little speed in order to link
>> > +                               ;; libraries and test executables in a
>> > +                               ;; reasonable amount of memory.
>> > +                               "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
>> > +                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
>> >      (home-page "https://www.webkit.org")
>> >      (synopsis "Web browser engine and classes to render and interact with web
>> >  content")
>>
>> I've tested this, and this fixed the qtwebkit build for me, which
>> currently doesn't work on master. So I'm all for merging it.
>
> Thanks for testing it.  I assume it was the linker flags that fixed the
> build on your machine?  For clarity, I suppose that change should be
> moved to a separate patch.  WDYT?

I don't mind eitherway, I'm just happy that the package builds again
with the patch :)
Eric Bavier Nov. 27, 2018, 2:04 a.m. UTC | #4
On Mon, 19 Nov 2018 22:22:44 -0600
Eric Bavier <ericbavier@centurylink.net> wrote:

> Hi Christopher,
> 
> On Mon, 19 Nov 2018 22:22:58 +0000
> Christopher Baines <mail@cbaines.net> wrote:
> 
> > ericbavier@centurylink.net writes:
> >   
> > > From: Eric Bavier <bavier@member.fsf.org>
> > >
> > > This lets qmake find qtwebkit components, allowing packages like python-pyqt
> > > to find qtwebkit and enable support.
> > >
> > > * gnu/packages/qt.scm (qtwebkit)[arguments]: Add "ECM_MKSPECS_INSTALL_DIR"
> > > to #:configure-flags.  Link with "--no-keep-memory".
> > > ---
> > >  gnu/packages/qt.scm | 11 ++++++++++-
> > >  1 file changed, 10 insertions(+), 1 deletion(-)
> > >
> > > diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
> > > index d48769982..36f8aef69 100644
> > > --- a/gnu/packages/qt.scm
> > > +++ b/gnu/packages/qt.scm
> > > @@ -10,6 +10,7 @@
> > >  ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
> > >  ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> > >  ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
> > > +;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> > >  ;;;
> > >  ;;; This file is part of GNU Guix.
> > >  ;;;
> > > @@ -2171,7 +2172,15 @@ different kinds of sliders, and much more.")
> > >         #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
> > >                                 "-DPORT=Qt"
> > >                                 "-DUSE_LIBHYPHEN=OFF"
> > > -                               "-DUSE_SYSTEM_MALLOC=ON")))
> > > +                               "-DUSE_SYSTEM_MALLOC=ON"
> > > +                               ;; XXX: relative dir installs to build dir?
> > > +                               (string-append "-DECM_MKSPECS_INSTALL_DIR="
> > > +                                              %output "/lib/qt5/mkspecs/modules")
> > > +                               ;; Sacrifice a little speed in order to link
> > > +                               ;; libraries and test executables in a
> > > +                               ;; reasonable amount of memory.
> > > +                               "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
> > > +                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
> > >      (home-page "https://www.webkit.org")
> > >      (synopsis "Web browser engine and classes to render and interact with web
> > >  content")    
> > 
> > I've tested this, and this fixed the qtwebkit build for me, which
> > currently doesn't work on master. So I'm all for merging it.  
> 
> Thanks for testing it.  I assume it was the linker flags that fixed the
> build on your machine?  For clarity, I suppose that change should be
> moved to a separate patch.  WDYT?

I've split this patch in two and pushed as

0995a5692cb85418b2d5f21c24d46ee4aa9fb7c9 and
ebdb15bc3540b1901f223bc0689bae51a2f88fc4

`~Eric

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d48769982..36f8aef69 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2018 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2171,7 +2172,15 @@  different kinds of sliders, and much more.")
        #:configure-flags (list ;"-DENABLE_API_TESTS=TRUE"
                                "-DPORT=Qt"
                                "-DUSE_LIBHYPHEN=OFF"
-                               "-DUSE_SYSTEM_MALLOC=ON")))
+                               "-DUSE_SYSTEM_MALLOC=ON"
+                               ;; XXX: relative dir installs to build dir?
+                               (string-append "-DECM_MKSPECS_INSTALL_DIR="
+                                              %output "/lib/qt5/mkspecs/modules")
+                               ;; Sacrifice a little speed in order to link
+                               ;; libraries and test executables in a
+                               ;; reasonable amount of memory.
+                               "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,--no-keep-memory"
+                               "-DCMAKE_EXE_LINKER_FLAGS=-Wl,--no-keep-memory")))
     (home-page "https://www.webkit.org")
     (synopsis "Web browser engine and classes to render and interact with web
 content")