[bug#33290,1/8] gnu: go-github-com-prometheus-common-expfmt: Disable tests for go-1.11.

Message ID 20181106171608.24187-1-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#33290,1/8] gnu: go-github-com-prometheus-common-expfmt: Disable tests for go-1.11. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Pierre Neidhardt Nov. 6, 2018, 5:16 p.m. UTC
* gnu/packages/syncthing.scm (go-github-com-prometheus-common-expfmt): Disable tests for go-1.11.
---
 gnu/packages/syncthing.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

Comments

Leo Famulari Nov. 6, 2018, 5:33 p.m. UTC | #1
On Tue, Nov 06, 2018 at 06:16:08PM +0100, Pierre Neidhardt wrote:
> * gnu/packages/syncthing.scm (go-github-com-prometheus-common-expfmt): Disable tests for go-1.11.

> +               #t)))
> +         ;; Tests don't pass on go-1.11.  See
> +         ;; https://github.com/syncthing/syncthing/issues/5311.
> +         #:tests? #f))

Thanks for looking into this! Do you know if only the tests are broken?
Or is the functionality of this package broken as well?
Pierre Neidhardt Nov. 6, 2018, 5:34 p.m. UTC | #2
From what I've investigated, the failures are only "lints" (check the link, I've
reported this) so nothing should break.

Patch

diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 48b52d200..410015c48 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1097,7 +1097,10 @@  message streaming.")
                       (string-append (assoc-ref outputs "out")
                                      "/src/github.com/prometheus/common/expfmt/testdata/")
                       ".*\\.gz$"))
-               #t)))))
+               #t)))
+         ;; Tests don't pass on go-1.11.  See
+         ;; https://github.com/syncthing/syncthing/issues/5311.
+         #:tests? #f))
       (propagated-inputs
        `(("go-github-com-golang-protobuf-proto"
           ,go-github-com-golang-protobuf-proto)