[bug#33173] gnu: linux-libre: Enable BOCHS DRM support.

Message ID 20181027083051.7817-1-m.othacehe@gmail.com
State Accepted
Commit 81f12f33b70855c0a99d5c2f1c2526e4a21b9823
Headers show
Series [bug#33173] gnu: linux-libre: Enable BOCHS DRM support. | expand

Commit Message

Mathieu Othacehe Oct. 27, 2018, 8:30 a.m. UTC
* gnu/packages/aux-files/linux-libre/4.19-x86_64.conf: Build DRM BOCHS support
as a module.  It adds DRM support for BOCHS dispi vga interface used by
qemu (-vga std option). It will also be useful for QEMU 3.0 to enable the new
"bochs-display" display device.
* gnu/packages/aux-files/linux-libre/4.19-i686.conf: Ditto.
---
 gnu/packages/aux-files/linux-libre/4.19-i686.conf   | 2 +-
 gnu/packages/aux-files/linux-libre/4.19-x86_64.conf | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

Comments

Mathieu Othacehe Oct. 27, 2018, 8:41 a.m. UTC | #1
Hi,

This article might help to understand what's new in QEMU 3.0 with VGA
emulation.

https://www.kraxel.org/blog/2018/10/qemu-vga-emulation-and-bochs-display/

Thanks,

Mathieu

Mathieu Othacehe writes:

> * gnu/packages/aux-files/linux-libre/4.19-x86_64.conf: Build DRM BOCHS support
> as a module.  It adds DRM support for BOCHS dispi vga interface used by
> qemu (-vga std option). It will also be useful for QEMU 3.0 to enable the new
> "bochs-display" display device.
> * gnu/packages/aux-files/linux-libre/4.19-i686.conf: Ditto.
> ---
>  gnu/packages/aux-files/linux-libre/4.19-i686.conf   | 2 +-
>  gnu/packages/aux-files/linux-libre/4.19-x86_64.conf | 2 +-
>  2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/aux-files/linux-libre/4.19-i686.conf b/gnu/packages/aux-files/linux-libre/4.19-i686.conf
> index 07a035be9..c1df3f0f4 100644
> --- a/gnu/packages/aux-files/linux-libre/4.19-i686.conf
> +++ b/gnu/packages/aux-files/linux-libre/4.19-i686.conf
> @@ -5949,7 +5949,7 @@ CONFIG_DRM_AST=m
>  # CONFIG_DRM_MGAG200 is not set
>  CONFIG_DRM_CIRRUS_QEMU=m
>  CONFIG_DRM_QXL=m
> -# CONFIG_DRM_BOCHS is not set
> +CONFIG_DRM_BOCHS=m
>  CONFIG_DRM_VIRTIO_GPU=m
>  CONFIG_DRM_PANEL=y
>  
> diff --git a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
> index 0e102c87d..a8f8c8164 100644
> --- a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
> +++ b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
> @@ -5853,7 +5853,7 @@ CONFIG_DRM_AST=m
>  # CONFIG_DRM_MGAG200 is not set
>  CONFIG_DRM_CIRRUS_QEMU=m
>  CONFIG_DRM_QXL=m
> -# CONFIG_DRM_BOCHS is not set
> +CONFIG_DRM_BOCHS=m
>  CONFIG_DRM_VIRTIO_GPU=m
>  CONFIG_DRM_PANEL=y
Ludovic Courtès Oct. 27, 2018, 9:18 p.m. UTC | #2
Hello Mathieu,

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> This article might help to understand what's new in QEMU 3.0 with VGA
> emulation.
>
> https://www.kraxel.org/blog/2018/10/qemu-vga-emulation-and-bochs-display/

Looks interesting.

>> * gnu/packages/aux-files/linux-libre/4.19-x86_64.conf: Build DRM BOCHS support
>> as a module.  It adds DRM support for BOCHS dispi vga interface used by
>> qemu (-vga std option). It will also be useful for QEMU 3.0 to enable the new
>> "bochs-display" display device.
>> * gnu/packages/aux-files/linux-libre/4.19-i686.conf: Ditto.

Perhaps we should enable it on AArch64 as well?  Mostly so that configs
don’t diverge too much.

Otherwise it LGTM.  Mark, WDYT?

Thanks,
Ludo’.
Mathieu Othacehe Oct. 28, 2018, 1:58 a.m. UTC | #3
Hi Ludo,

> Perhaps we should enable it on AArch64 as well?  Mostly so that configs
> don’t diverge too much.

It is already built as a module on our arm and arm64 configs. The arm
config was taken from Debian and not derived from GuixSD intel configs,
so it explains the divergence. I guess it is the same for the arm64
config.

Thanks,

Mathieu
Mark H Weaver Oct. 28, 2018, 2:28 a.m. UTC | #4
ludo@gnu.org (Ludovic Courtès) writes:

> Mathieu Othacehe <m.othacehe@gmail.com> skribis:
>
>> This article might help to understand what's new in QEMU 3.0 with VGA
>> emulation.
>>
>> https://www.kraxel.org/blog/2018/10/qemu-vga-emulation-and-bochs-display/
>
> Looks interesting.
>
>>> * gnu/packages/aux-files/linux-libre/4.19-x86_64.conf: Build DRM BOCHS support
>>> as a module.  It adds DRM support for BOCHS dispi vga interface used by
>>> qemu (-vga std option). It will also be useful for QEMU 3.0 to enable the new
>>> "bochs-display" display device.
>>> * gnu/packages/aux-files/linux-libre/4.19-i686.conf: Ditto.

Looks good to me, please push.

> Perhaps we should enable it on AArch64 as well?  Mostly so that configs
> don’t diverge too much.

I just checked, and it's already enabled in our ARM and ARM64 configs.

FYI, our x86_64 and i686 configs were originally copied from
<https://jxself.org/git/kernel-configs.git>, and that's where the
decision to disable CONFIG_DRM_BOCHS originally came from.  In that
repo, you can see signs of indecision about whether to include that
module.  It was disabled in Jason's configs for 3.14-4.6, enabled in
4.7-4.15, disabled again in 4.16-4.18, and then enabled again in 4.19.

Since around 4.1 or 4.2, I've stopped looking at
<https://jxself.org/git/kernel-configs.git> and been using my own
judgement about new kernel configuration options brought to my attention
by "make oldconfig", but I haven't reviewed most of the older options.

Anyway, thanks for the patch!

       Mark
Mathieu Othacehe Oct. 28, 2018, 11:59 a.m. UTC | #5
Hi Mark,

> FYI, our x86_64 and i686 configs were originally copied from
> <https://jxself.org/git/kernel-configs.git>, and that's where the
> decision to disable CONFIG_DRM_BOCHS originally came from.  In that
> repo, you can see signs of indecision about whether to include that
> module.  It was disabled in Jason's configs for 3.14-4.6, enabled in
> 4.7-4.15, disabled again in 4.16-4.18, and then enabled again in 4.19.
>
> Since around 4.1 or 4.2, I've stopped looking at
> <https://jxself.org/git/kernel-configs.git> and been using my own
> judgement about new kernel configuration options brought to my attention
> by "make oldconfig", but I haven't reviewed most of the older options.
>
> Anyway, thanks for the patch!

Thank you for the explanation and the review! Pushed as
81f12f33b70855c0a99d5c2f1c2526e4a21b9823.

Mathieu

Patch

diff --git a/gnu/packages/aux-files/linux-libre/4.19-i686.conf b/gnu/packages/aux-files/linux-libre/4.19-i686.conf
index 07a035be9..c1df3f0f4 100644
--- a/gnu/packages/aux-files/linux-libre/4.19-i686.conf
+++ b/gnu/packages/aux-files/linux-libre/4.19-i686.conf
@@ -5949,7 +5949,7 @@  CONFIG_DRM_AST=m
 # CONFIG_DRM_MGAG200 is not set
 CONFIG_DRM_CIRRUS_QEMU=m
 CONFIG_DRM_QXL=m
-# CONFIG_DRM_BOCHS is not set
+CONFIG_DRM_BOCHS=m
 CONFIG_DRM_VIRTIO_GPU=m
 CONFIG_DRM_PANEL=y
 
diff --git a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
index 0e102c87d..a8f8c8164 100644
--- a/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
+++ b/gnu/packages/aux-files/linux-libre/4.19-x86_64.conf
@@ -5853,7 +5853,7 @@  CONFIG_DRM_AST=m
 # CONFIG_DRM_MGAG200 is not set
 CONFIG_DRM_CIRRUS_QEMU=m
 CONFIG_DRM_QXL=m
-# CONFIG_DRM_BOCHS is not set
+CONFIG_DRM_BOCHS=m
 CONFIG_DRM_VIRTIO_GPU=m
 CONFIG_DRM_PANEL=y