[bug#33148] gnu: Add jp2a.

Message ID 20181025102816.20497-1-contact@parouby.fr
State Accepted
Headers show
Series [bug#33148] gnu: Add jp2a. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

parouby Oct. 25, 2018, 10:28 a.m. UTC
* gnu/packages/image.scm: New variable.
---
 gnu/packages/image.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Patch

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index b367e0799..6e3c6cc18 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2018 Fis Trivial <ybbs.daans@hotmail.com>
 ;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -43,6 +44,7 @@ 
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
@@ -1497,3 +1499,29 @@  Two other programs are included with Gifsicle: @command{gifview} is a
 lightweight animated-GIF viewer, and @command{gifdiff} compares two GIFs for
 identical visual appearance.")
    (license license:gpl2+)))
+
+(define-public jp2a
+  (package
+    (name "jp2a")
+    (version "1.0.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/cslarsen/jp2a/archive/v"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0nahpjvrahixcfqqrjj2k4fscc8qs4hqnmj2qgjzsjj3z6xxh2g5"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("libjpeg" ,libjpeg)
+       ("curl" ,curl)))
+    (native-inputs
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://csl.name/jp2a/")
+    (synopsis "Converts JPG images to ASCII")
+    (description "Jp2a is a small utility that converts JPG images to
+ASCII.")
+    (license license:gpl2)))