diff mbox series

[bug#51923] gnu: Add megapixels.

Message ID 1vMgyrQNafwkMS0fIpN4mfDx99qF7xXbrXm_sCn6ysww4GrF4zowVOX2LzUzvgC33fu6zlCrPKQTpas0kymx5ME2BmRRNON5m0cmlh9Lrbs=@protonmail.com
State New
Headers show
Series [bug#51923] gnu: Add megapixels. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 17, 2021, 4:07 p.m. UTC
Hi,

this adds support for the camera on PinePhone.

Also when I run lint it errors:

ice-9/boot-9.scm:1685:16: In procedure raise-exception:
error: remote-refs: unbound variable

The problem is in the updater not handling the url https://git.sr.ht/~martijnbraam/megapixels.

* gnu/packages/gnome.scm (megapixels): New variable.


base-commit: b7b982228a7256afcb83d0b05a098139c2e1a644
--
2.33.0

Comments

Tobias Geerinckx-Rice Nov. 17, 2021, 5:47 p.m. UTC | #1
Petr,

'Nother quickie.

On 2021-11-17 17:07, phodina via Guix-patches via wrote:
> The problem is in the updater not handling the url
> https://git.sr.ht/~martijnbraam/megapixels.

Good thing 'he development and maintainership of Megapixels has been 
moved to gitlab.com/postmarketos/megapixels' then :-)

Could you update the URL and try again?  If you want you can report 
and/or investigate Guix's apparent failure to deal with sr.ht 
separately.

> +       (file-name (string-append name "-" version ".tar.gz"))
                                                      ^^^^^^^^^
Use git-file-name here for convenience and to reduce the chances of such 
paste-os.

> +    (native-inputs `(("pkg-config" ,pkg-config)
> +                     ("gtk:bin"
> +                      ,gtk "bin")       ; for gtk-update-icon-cache
> +                     ("glib:bin"
> +                      ,glib "bin")      ; glib-compile-schemas, etc.
> +                     ("desktop-file-utils"
> +                      ,desktop-file-utils) ; for 
> update-desktop-database
> +                     ("zbar" ,zbar)
> +                     ("libtiff" ,libtiff)
> +                     ("cmake" ,cmake)))

Please add a newline after native-inputs so you don't have to split 
inputs over 2 lines like this.  Since we're here anyway, order these 
alphabetically.

> +    (inputs `(("libhandy" ,libhandy)
> +              ("perl-image-exiftool" ,perl-image-exiftool)
> +              ("imagemagick" ,imagemagick)
> +              ("libraw" ,libraw)
> +              ("gtk" ,gtk)))

Same newline.

> +    (synopsis "Camera application")

So... ignoring the redundant 'application', this is a one-word synopsis. 
  This seems to be for mobile devices, so 'Camera applications for mobile 
devices', I guess.

> +    (description "This package provides camera application that knows
> +how to deal with the media request api.")

Whose obscure 'media request API'?  Why does that matter?  Etc.

This seems (more?) pertinent:

- Megapixels only captures raw frames and stores .dng files.
- It captures a 5 frame burst and saves it to a temporary location.
- It runs a (customisable? dunno) postprocessing script to generate the 
final JPEG file and saves it to the Pictures directory.
- It uses OpenGL to debayer the raw sensor data for the preview.

Etc.  Descriptions should not be 1-2 lines long.

> +    (home-page "https://git.sr.ht/~martijnbraam/megapixels")

Also update to GitLab?

I'll build this later today, but I don't expect to find any issues with 
the package :-)

Kind regards,

T G-R

Sent from a Web browser.  Excuse or enjoy my brevity.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 19520f335a..7d53784533 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1137,6 +1137,42 @@  freedesktop.org desktop notification specification.")
     (home-page "https://wiki.gnome.org/Projects/NotificationDaemon")
     (license license:gpl2+)))

+(define-public megapixels
+  (package
+    (name "megapixels")
+    (version "1.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~martijnbraam/megapixels")
+             (commit version)))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0dagp1sh5whnnllrydk7ijjid0hmvcbdm8kkzq2g168khdfn80jm"))))
+    (build-system meson-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("gtk:bin"
+                      ,gtk "bin")       ; for gtk-update-icon-cache
+                     ("glib:bin"
+                      ,glib "bin")      ; glib-compile-schemas, etc.
+                     ("desktop-file-utils"
+                      ,desktop-file-utils) ; for update-desktop-database
+                     ("zbar" ,zbar)
+                     ("libtiff" ,libtiff)
+                     ("cmake" ,cmake)))
+    (inputs `(("libhandy" ,libhandy)
+              ("perl-image-exiftool" ,perl-image-exiftool)
+              ("imagemagick" ,imagemagick)
+              ("libraw" ,libraw)
+              ("gtk" ,gtk)))
+    (synopsis "Camera application")
+    (description "This package provides camera application that knows
+how to deal with the media request api.")
+    (home-page "https://git.sr.ht/~martijnbraam/megapixels")
+    (license license:gpl3+)))
+
 (define-public mm-common
   (package
     (name "mm-common")