diff mbox series

[bug#58955] gnu: pd: Update to 0.53-0, unbundle oss and portaudio

Message ID 1iy1gGLmq4QENuFNQ_0_KrSIcwZ6VL1WHMIRlmbaDs-1OAU8vbTqD139NyBUZaka27bxvFSBERpMqV_imzqOgMWsRFqWvOaMaC_Xs6Vva4k=@proton.me
State New
Headers show
Series [bug#58955] gnu: pd: Update to 0.53-0, unbundle oss and portaudio | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sughosha Nov. 2, 2022, 1:28 a.m. UTC
* gnu/packages/music.scm (pd): Update to 0.53-0.
[arguments]: Unbundle oss and portaudio.
[inputs]: Add portaudio.
---
 gnu/packages/music.scm | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

--
libgit2 1.4.3

Comments

Christopher Baines Nov. 3, 2022, 5:27 p.m. UTC | #1
Sughosha via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/music.scm (pd): Update to 0.53-0.
> [arguments]: Unbundle oss and portaudio.
> [inputs]: Add portaudio.
> ---
>  gnu/packages/music.scm | 8 +++++---
>  1 file changed, 5 insertions(+), 3 deletions(-)

Hey Sughosha,

I'm having a bit of trouble matching up the commit message with the
changes being made.

From the diff, it looks like oss is being disabled, rather than
unbundled. What's the reasoning behind disabling it?

Adding portaudio as an input seems fine I guess, but it might be good to
remove the portaudio files from the source (through a snippet) if there
are some there.

Thanks,

Chris
Sughosha Nov. 4, 2022, 1:29 p.m. UTC | #2
Hi Christopher,

Thanks for reviewing the patch.

> From the diff, it looks like oss is being disabled, rather than
> unbundled. What's the reasoning behind disabling it?
OSS is not needed since it was superseded by ALSA and it does the job.
I disabled it because it's not at all used in Guix and also not needed
as we have ALSA. Sorry for not being accurate in the message.
> 
> Adding portaudio as an input seems fine I guess, but it might be good to
> remove the portaudio files from the source (through a snippet) if there
> are some there.
I tried it but autoconf or automake looks for it and gives error, before
starting building.
宋文武 Jan. 29, 2023, 6:56 a.m. UTC | #3
Sughosha <Sughosha@proton.me> writes:

> Hi Christopher,
>
> Thanks for reviewing the patch.
>
>> From the diff, it looks like oss is being disabled, rather than
>> unbundled. What's the reasoning behind disabling it?
> OSS is not needed since it was superseded by ALSA and it does the job.
> I disabled it because it's not at all used in Guix and also not needed
> as we have ALSA. Sorry for not being accurate in the message.
>> 
>> Adding portaudio as an input seems fine I guess, but it might be good to
>> remove the portaudio files from the source (through a snippet) if there
>> are some there.
> I tried it but autoconf or automake looks for it and gives error, before
> starting building.

Pushed with adjusted commit message, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ca400e8..b018c8e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2693,24 +2693,26 @@  export.")
 (define-public pd
   (package
     (name "pd")
-    (version "0.52-2")
+    (version "0.53-0")
     (source (origin
               (method url-fetch)
               (uri
                (string-append "http://msp.ucsd.edu/Software/pd-"
                               version ".src.tar.gz"))
               (sha256
                (base32
-                "04fcsfgnv2r7g7p8vk9s9n3wba1bx4xgqw5mhwv09xbw9s3gapg9"))))
+                "01zcgw4bg4r422ikqa0d4s7vpgjjz76scnm4l1msnm35y7pzknns"))))
     (build-system gnu-build-system)
     (arguments
      (let ((wish (string-append "wish" (version-major+minor
                                         (package-version tk)))))
        (list
         #:tests? #f                     ; no "check" target
         #:configure-flags
         #~(list
+           "--disable-oss"
            "--enable-jack"
+           "--without-local-portaudio"
            (string-append "--with-wish="
                           (search-input-file %build-inputs
                                              (string-append "/bin/" #$wish))))
@@ -2724,7 +2726,7 @@  export.")
     (native-inputs
      (list autoconf automake libtool gettext-minimal pkg-config))
     (inputs
-     (list tk alsa-lib jack-1))
+     (list tk alsa-lib jack-1 portaudio))
     (home-page "https://puredata.info")
     (synopsis "Visual programming language for artistic performances")
     (description