diff mbox series

[bug#70224,1/2] gnu: c-toxcore: Update to 0.2.19.

Message ID 1f80fc5b8d0b0f10e7bc9097a7ac55f14305e028.1712364159.git.monego@posteo.net
State New
Headers show
Series Update c-toxcore and toxic. | expand

Commit Message

Vinicius Monego April 6, 2024, 12:47 a.m. UTC
* gnu/packages/messaging.scm (c-toxcore): Update to 0.2.19.
[source]: Fetch sources recursively.
[arguments]<#:configure-flags>: Use G-Expressions. Pass "-DENABLE_STATIC=false".

Change-Id: I42fc47b45e1afdbb2c60c80bc56e1b839923ec34
---
 gnu/packages/messaging.scm | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 03b7368ae0..0cd02ae348 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -29,7 +29,7 @@ 
 ;;; Copyright © 2020, 2021 Robert Karszniewicz <avoidr@posteo.de>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2021, 2023 Denis 'GNUtoo' Carikli <GNUtoo@cyberdimension.org>
-;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021, 2024 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 jgart <jgart@dismail.de>
 ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
@@ -1666,20 +1666,24 @@  (define-public libtoxcore
 (define-public c-toxcore
   (package
     (name "c-toxcore")
-    (version "0.2.12")
+    (version "0.2.19")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/TokTok/c-toxcore")
-             (commit (string-append "v" version))))
+             (commit (string-append "v" version))
+             ;; XXX: c-toxcore now depends on a package called 'cmp', an
+             ;; implementation of MessagePack in C.  Fetch the submodule
+             ;; for now, maybe package it later.
+             (recursive? #t)))
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0a6sqpm00d2rn0nviqfz4gh9ck1wzci6rxgmqmcyryl5ca19ffvp"))))
+         "0wq6grc5lfjip39gm0ji1cw6b1sdv1zvimg1g40haqzhj51755za"))))
     (arguments
-     `(#:tests? #f)) ; FIXME: Testsuite seems to stay stuck on test 3. Disable
-                     ; for now.
+     (list #:tests? #f ; figure out how to run the tests
+           #:configure-flags #~(list "-DENABLE_STATIC=false")))
     (build-system cmake-build-system)
     (native-inputs
      (list pkg-config))