diff mbox series

[bug#60633] gnu: Add kiln.

Message ID 1f605d00c3267973eae7af26817a308a304209bf.1673116311.git.sikmir@disroot.org
State New
Headers show
Series [bug#60633] gnu: Add kiln. | expand

Commit Message

Nikolay Korotkiy Jan. 7, 2023, 6:32 p.m. UTC
* gnu/packages/web.scm (kiln): New variable.
---
 gnu/packages/web.scm | 38 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 38 insertions(+)


base-commit: d16edd03cfa84f6d5fed979fd7283966cd3e4934

Comments

Nicolas Goaziou March 10, 2023, 9:16 p.m. UTC | #1
Hello,

Nikolay Korotkiy via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/web.scm (kiln): New variable.

Applied. Thank you.

> +    (arguments
> +     `(#:import-path "git.sr.ht/~adnano/kiln"

I used G-expressions.

> +       #:install-source? #f
> +       #:phases (modify-phases %standard-phases
> +                  (add-after 'install 'install-man
> +                    (lambda* (#:key outputs #:allow-other-keys)
> +                      (let* ((out (assoc-ref outputs "out"))
> +                             (man1 (string-append out "/share/man/man1")))
> +                        (system
> +                         "scdoc < src/git.sr.ht/~adnano/kiln/docs/kiln.1.scd > kiln.1")
> +                        (mkdir-p man1)
> +                        (install-file "kiln.1" man1)) #t)))))

I removed the trailing #T.

> +    (propagated-inputs (list go-github-com-google-shlex
> +                             go-github-com-pelletier-go-toml
> +                             go-gopkg-in-yaml-v3))
> +    (native-inputs (list scdoc))
> +    (home-page "https://kiln.adnano.co/")
> +    (synopsis "A simple static site generator")

I removed the article "A".

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index dcb7b3872a..e7ad92c442 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -7997,6 +7997,44 @@  (define-public gmid
 @end itemize")
     (license license:isc)))
 
+(define-public kiln
+  (package
+    (name "kiln")
+    (version "0.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~adnano/kiln")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1lvzv46hn80gffw47mcc28iahwqng7pvg500s9jlrq6mhr4k5ih4"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:import-path "git.sr.ht/~adnano/kiln"
+       #:install-source? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'install 'install-man
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (let* ((out (assoc-ref outputs "out"))
+                             (man1 (string-append out "/share/man/man1")))
+                        (system
+                         "scdoc < src/git.sr.ht/~adnano/kiln/docs/kiln.1.scd > kiln.1")
+                        (mkdir-p man1)
+                        (install-file "kiln.1" man1)) #t)))))
+    (propagated-inputs (list go-github-com-google-shlex
+                             go-github-com-pelletier-go-toml
+                             go-gopkg-in-yaml-v3))
+    (native-inputs (list scdoc))
+    (home-page "https://kiln.adnano.co/")
+    (synopsis "A simple static site generator")
+    (description
+     "kiln takes a different approach to building static sites.
+Instead of packing all functionality into kiln itself, the core is lightweight
+and can be extended with the use of external commands.")
+    (license license:expat)))
+
 (define-public siege
   (package
     (name "siege")