diff mbox series

[bug#44982] gnu: Add python-bitstring.

Message ID 1f4016e9bebcaf1d5d1be27d6d3ee339cc0a7bc5.camel@free.fr
State Accepted
Headers show
Series [bug#44982] gnu: Add python-bitstring. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 1, 2020, 5:27 a.m. UTC
Thanks!

Comments

dftxbs3e Dec. 1, 2020, 9:01 a.m. UTC | #1
This can be reviewed in the context of #44984 instead.

Please close, sorry, thanks!
Simon Tournier Dec. 1, 2020, 9:22 a.m. UTC | #2
Hi,

On Tue, 01 Dec 2020 at 10:01, dftxbs3e <dftxbs3e@free.fr> wrote:
> This can be reviewed in the context of #44984 instead.
>
> Please close, sorry, thanks!

You can close by sending to 44982-done@debbugs.gnu.org.  Or apply any
other operations by reading:

  <https://debbugs.gnu.org/server-control.html>

All the best,
simon
diff mbox series

Patch

From 4196b2a9fb1a73537cd607d0a6ea40d9df3a83b0 Mon Sep 17 00:00:00 2001
From: John Doe <dftxbs3e@free.fr>
Date: Tue, 1 Dec 2020 06:19:05 +0100
Subject: [PATCH] gnu: Add python-bitstring.

* gnu/packages/python-xyz.scm (python-bitstring): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1086d724f1..87c0d3495a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23232,3 +23232,23 @@  process.")
      "Gamera is a toolkit for building document image recognition systems.")
     (home-page "https://gamera.informatik.hsnr.de/")
     (license license:gpl2+)))
+
+(define-public python-bitstring
+  (package
+    (name "python-bitstring")
+    (version "3.1.7")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "bitstring" version))
+        (sha256
+          (base32
+            "0jl6192dwrlm5ybkbh7ywmyaymrc3cmz9y07nm7qdli9n9rfpwzx"))))
+    (build-system python-build-system)
+    (home-page
+      "https://github.com/scott-griffiths/bitstring")
+    (synopsis
+      "Simple construction, analysis and modification of binary data.")
+    (description
+      "Simple construction, analysis and modification of binary data.")
+    (license license:expat)))
-- 
2.28.0