diff mbox series

[bug#72835,qt-team,v2,34/74] gnu: python-sip: Update to 6.8.6.

Message ID 1f1866964d855b6cf285debfa383f75132cce8c1.1726567073.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt{5,6}. | expand

Commit Message

Z572 Sept. 18, 2024, 1:43 a.m. UTC
* gnu/packages/qt.scm (python-sip): Update to 6.8.6.
[native-inputs]: Add python-setuptools and python-setuptools-scm-next.
[arguments]: Disable tests.

Change-Id: If063d7194711053a4e65ab513573eb6d593e9446
---
 gnu/packages/qt.scm | 26 ++++++++++++++------------
 1 file changed, 14 insertions(+), 12 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 1774c69ca4..945d418ec0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -3930,24 +3930,26 @@  (define-public pyotherside-for-qt5
 (define-public python-sip
   (package
     (name "python-sip")
-    (version "6.8.3")
+    (version "6.8.6")
     (source
-      (origin
-        (method url-fetch)
-        (uri (list (pypi-uri "sip" version)
-                   (string-append "https://www.riverbankcomputing.com/static/"
-                                  "Downloads/sip/" version
-                                  "/sip-" version ".tar.gz")))
-        (sha256
-         (base32
-          "0b3n237lbggz3b6bfmdsl1m4qgai7qyyj6fmvrmc695v32q4g1c8"))
-        (patches (search-patches "python-sip-include-dirs.patch"))))
+     (origin
+       (method url-fetch)
+       (uri (list (pypi-uri "sip" version)
+                  (string-append "https://www.riverbankcomputing.com/static/"
+                                 "Downloads/sip/" version
+                                 "/sip-" version ".tar.gz")))
+       (sha256
+        (base32
+         "0ykxq0607f2sdwbl5cxbp0y8pl14bsgzc9nhifpxbibfivj5kjbz"))
+       (patches (search-patches "python-sip-include-dirs.patch"))))
     (build-system pyproject-build-system)
     (native-inputs
-     (list python-wrapper))
+     (list python-wrapper python-setuptools python-setuptools-scm-next))
     (propagated-inputs
      (list python-tomli
            python-packaging))
+    ;; no test.
+    (arguments (list #:tests? #f))
     (home-page "https://www.riverbankcomputing.com/software/sip/intro")
     (synopsis "Python binding creator for C and C++ libraries")
     (description