[bug#78122] gnu: cni-plugins: Update to 1.7.1.
Commit Message
* gnu/packages/containers.scm (cni-plugins)[version]: Update to 1.7.1.
[arguments]<#:go>: Set to go-1.23.
Change-Id: I0c28e224501ea0e67cde8104d8bfa573751f4c9b
---
gnu/packages/containers.scm | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
@@ -342,7 +342,7 @@ (define-public passt
(define-public cni-plugins
(package
(name "cni-plugins")
- (version "1.6.1")
+ (version "1.7.1")
(source
(origin
(method git-fetch)
@@ -350,12 +350,13 @@ (define-public cni-plugins
(url "https://github.com/containernetworking/plugins")
(commit (string-append "v" version))))
(sha256
- (base32 "164savm1iic5ax2xi4zgy9lm7wk8kjy22n4is463lj9rkbp4s6xn"))
+ (base32 "04acfjkc3z2yf85z0v1mlgj0fqy032dsklzik2g1cnz6ncw6jl2b"))
(file-name (git-file-name name version))))
(build-system go-build-system)
(arguments
`(#:unpack-path "github.com/containernetworking/plugins"
#:tests? #f ; XXX: see stat /var/run below
+ #:go ,go-1.23
#:phases (modify-phases %standard-phases
(replace 'build
(lambda _
@@ -364,7 +365,7 @@ (define-public cni-plugins
(invoke "./build_linux.sh"))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
- ; only pkg/ns tests run without root
+ ;; Only pkg/ns tests run without root.
(when tests?
(with-directory-excursion
"src/github.com/containernetworking/plugins/pkg/ns"