[bug#78059,electronics-team] gnu: Add abc-yosyshq.

Message ID 1f03c394302b446798f46d1e1495ca1367a7cdb4.1745585324.git.csantosb@inventati.org
State New
Headers
Series [bug#78059,electronics-team] gnu: Add abc-yosyshq. |

Commit Message

Cayetano Santos April 25, 2025, 12:48 p.m. UTC
  * gnu/packages/fpga.scm (abc-yosyshq): New variable.

https://github.com/YosysHQ/abc is a fork of berkeley abc, used by all
yosyshq projects (yosys, etc.).

Change-Id: I46649e3722ded3faf8c0993d7bebaf649e6297c6
---

There are (at least) two versions of abc:

- https://github.com/berkeley-abc/abc, from berkely, that we currently package
- https://github.com/YosysHQ/abc, a fork by yosyshq

Yosys and remaining yosyshq software we package uses the later, while we are using the former. This produces errors in tests. We need then to package yosyshq version so that we may use it with all of their packages.

 gnu/packages/fpga.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)


base-commit: 501a9603f5e3cda07f3be8e7fecac31f7af5ce52
--
2.49.0
  

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index e1043efc48..a98bca8578 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -156,6 +156,40 @@  (define-public iverilog
     ;; You have to accept both GPL2 and LGPL2.1+.
     (license (list license:gpl2 license:lgpl2.1+))))
 
+(define-public abc-yosyshq
+  (package
+    (name "abc-yosyshq")
+    (version "0.52")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/YosysHQ/abc/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "15a7nyk8iqpadp326icnr7rn5pwq44b9lvajqc35hcsvixz4gxsa"))))
+    (build-system gnu-build-system)
+    (inputs
+     (list readline))
+    (arguments
+     (list
+      #:license-file-regexp "copyright.txt"
+      #:tests? #f ; no tests
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)
+          (replace 'install
+            (lambda _
+              (install-file "abc" (string-append #$output "/bin")))))))
+    (home-page "https://github.com/YosysHQ/abc/")
+    (synopsis "Sequential logic synthesis and formal verification")
+    (description "ABC is a program for sequential logic synthesis and
+formal verification.")
+    (license
+     (license:non-copyleft
+      "https://people.eecs.berkeley.edu/~alanmi/abc/copyright.htm"))))
+
 (define-public yosys
   (package
     (name "yosys")