[bug#78230] services: plasma-dbus-service: Fix kded not being started.

Message ID 1ef4bcdc9210d4c6874e190e88fd814ad08c44ec.1746282376.git.sergio.pastorperez@gmail.com
State New
Headers
Series [bug#78230] services: plasma-dbus-service: Fix kded not being started. |

Commit Message

Sergio Pastor Pérez May 3, 2025, 2:26 p.m. UTC
  `kded' is a daemon responsible for many features of the Plasma desktop, it
provides media keys handling, a system tray, 'Background Services' control
through 'kcmshell6 kcm_kded'...

* gnu/packages/kde-plasma.scm (plasma): Add `kded' to propagated inputs.

* gnu/packages/kde-plasma.scm (plasma-dbus-service): Add `kded' to the list of
services passed to `dbus-configuration'.

Change-Id: Ifffdaecdb28a6369727ab8d118a775d73ee342e9
---
 gnu/packages/kde-plasma.scm | 1 +
 gnu/services/desktop.scm    | 1 +
 2 files changed, 2 insertions(+)


base-commit: 12467f2c91e7f9ec70239229f8186a93193a9185
  

Patch

diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index efaae01aa9..8991dcf974 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1717,6 +1717,7 @@  (define-public plasma
                              kde-cli-tools
                              kdecoration
                              kde-gtk-config
+                             kded
                              kdeplasma-addons
                              kglobalaccel
                              kglobalacceld
diff --git a/gnu/services/desktop.scm b/gnu/services/desktop.scm
index 2127c2d389..fade9e0e14 100644
--- a/gnu/services/desktop.scm
+++ b/gnu/services/desktop.scm
@@ -2255,6 +2255,7 @@  (define (plasma-dbus-service config)
            "kwalletmanager"
            "powerdevil"
            "bluedevil"
+           "kded"
            "kwallet"
            "plasma-firewall"))))