diff mbox series

[bug#67232] gnu: Add clingo-dl.

Message ID 1ece7c79b117227b0ac1f6a81afbdf583b7fc1e4.1700159272.git.liliana.prikler@gmail.com
State New
Headers show
Series [bug#67232] gnu: Add clingo-dl. | expand

Commit Message

Liliana Marie Prikler Nov. 16, 2023, 6:27 p.m. UTC
* gnu/packages/potassco.scm (clingo-dl): New variable.

Change-Id: Ib6ff517435a614c3625d042453db05fe518241cd
---
 gnu/packages/potassco.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: 23627b1706af25a0a30b96b9169a3495279aff1b

Comments

Liliana Marie Prikler Nov. 23, 2023, 8:31 a.m. UTC | #1
Am Donnerstag, dem 16.11.2023 um 19:27 +0100 schrieb Liliana Marie
Prikler:
> * gnu/packages/potassco.scm (clingo-dl): New variable.
> 
> Change-Id: Ib6ff517435a614c3625d042453db05fe518241cd
> ---
Aaaaand it's pushed.
diff mbox series

Patch

diff --git a/gnu/packages/potassco.scm b/gnu/packages/potassco.scm
index e6d7caa1ef..887c220ccf 100644
--- a/gnu/packages/potassco.scm
+++ b/gnu/packages/potassco.scm
@@ -221,6 +221,28 @@  (define-public clingo
     (description "Clingo computes answer sets for a given logic program.")
     (license license:expat)))
 
+(define-public clingo-dl
+  (package
+    (name "clingo-dl")
+    (version "1.4.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/potassco/clingo-dl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "0dncwj63vdm6958vb7355d5j9mdr7hm037j4z82yz6l77jg3sipw"))))
+    (build-system cmake-build-system)
+    (arguments (list #:tests? #f        ; no tests
+                     #:configure-flags #~`("-DPYCLINGODL_ENABLE=off")))
+    (inputs (list clingo))
+    (home-page "https://github.com/potassco/clingo-dl")
+    (synopsis "Solver for answer set programs modulo difference constraints")
+    (description "Clingo-DL is an extension to Clingo that models constraints
+over difference logic.")
+    (license license:expat)))
+
 (define-public emacs-pasp-mode
   (let ((commit "59385eb0e8ebcfc8c11dd811fb145d4b0fa3cc92")
         (revision "1"))