[bug#75025] gnu: xfce4-power-manager: Fix guix system build caused by 2e6adef5a6.

Message ID 1eaa285072d54236d6747c35c318ead068f9bceb.1734879504.git.Rostislav.Svoboda@gmail.com
State New
Headers
Series [bug#75025] gnu: xfce4-power-manager: Fix guix system build caused by 2e6adef5a6. |

Commit Message

Rostislav Svoboda Dec. 22, 2024, 2:58 p.m. UTC
  * gnu/packages/xfce.scm (xfce4-power-manager): Fix guix system build problem
introduced by 2e6adef5a6. The `guix system build` fails with 'In procedure
opendir: No such file or directory' for
/gnu/store/70x83bfg3hqvsvhfrk5fw4m57wm6sb73-xfce4-power-manager-4.20.0.

Change-Id: Id18b3ed33c13ddf7669525bb0f516aed35ead117
---
 gnu/packages/xfce.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 1ca065fe68d68a2fa9c3d747f23fd11c8ecfd85b
  

Comments

宋文武 Dec. 23, 2024, 1:17 a.m. UTC | #1
Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> * gnu/packages/xfce.scm (xfce4-power-manager): Fix guix system build problem
> introduced by 2e6adef5a6. The `guix system build` fails with 'In procedure
> opendir: No such file or directory' for
> /gnu/store/70x83bfg3hqvsvhfrk5fw4m57wm6sb73-xfce4-power-manager-4.20.0.

Hello, I didn't meet this error, also it build successful on CI:
https://ci.guix.gnu.org/build/7464641/details

Indeed it missing polkit and panel plugin support, so I send an updated patch
to add them.

Thanks.
  
宋文武 Dec. 24, 2024, 5:12 a.m. UTC | #2
宋文武 <iyzsong@envs.net> writes:

> Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:
>
>> * gnu/packages/xfce.scm (xfce4-power-manager): Fix guix system build problem
>> introduced by 2e6adef5a6. The `guix system build` fails with 'In procedure
>> opendir: No such file or directory' for
>> /gnu/store/70x83bfg3hqvsvhfrk5fw4m57wm6sb73-xfce4-power-manager-4.20.0.
>
> Hello, I didn't meet this error, also it build successful on CI:
> https://ci.guix.gnu.org/build/7464641/details
>
> Indeed it missing polkit and panel plugin support, so I send an updated patch
> to add them.
>
> Thanks.

I had pushed the patch to add polkit and xfce-panel to inputs, but i
don't think it's the reason for the failed build you reported, which
maybe like filesystem (hardware) or parallel build issues (unlikely)...

Close this now, feel free to report again if it still fails.
  

Patch

diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 0c03b08f80..0ab3183c7f 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -1370,7 +1370,7 @@  (define-public xfce4-power-manager
     (native-inputs
      (list (list glib "bin") pkg-config intltool))
     (inputs
-     (list libxrandr gtk+ upower libnotify libxfce4ui))
+     (list libxrandr gtk+ upower libnotify libxfce4ui polkit))
     (home-page "https://www.xfce.org/")
     (synopsis "Xfce Power Manager")
     (description