[bug#77034,2/2] gnu: emacs-minimal: Adjust Guix paths in snippet.
Commit Message
* gnu/packages/emacs.scm (emacs-minimal)[source]: Add "/run/privileged/bin"
and Guix Home paths to ‘tramp-remote-path’.
Add Guix Home path to ‘Man-header-file-path’.
Change-Id: I20536ae93c74e06eafa5fd26a1b421680c177102
---
gnu/packages/emacs.scm | 14 +++++++++-----
1 file changed, 9 insertions(+), 5 deletions(-)
@@ -135,10 +135,13 @@ (define-public emacs-minimal
(substitute* "net/tramp.el"
;; Patch the line after "(defcustom tramp-remote-path".
(("\\(tramp-default-remote-path")
- (format #f "(tramp-default-remote-path ~s ~s ~s ~s "
- "~/.guix-profile/bin" "~/.guix-profile/sbin"
- "/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))
+ (format
+ #f "(tramp-default-remote-path ~s ~s ~s ~s ~s ~s ~s "
+ "/run/privileged/bin"
+ "~/.guix-profile/bin" "~/.guix-profile/sbin"
+ "~/.guix-home/bin" "~/.guix-home/sbin"
+ "/run/current-system/profile/bin"
+ "/run/current-system/profile/sbin")))
;; Make sure Man looks for C header files in the right
;; places.
@@ -147,7 +150,8 @@ (define-public emacs-minimal
(string-join
(list line
"\"~/.guix-profile/include\""
- "\"/var/guix/profiles/system/profile/include\"")
+ "\"~/.guix-home/include\""
+ "\"/run/current-system/profile/include\"")
" ")))))))
(build-system gnu-build-system)
(arguments