From befe35fd309355cb7aa0bfeda97142f4f8064958 Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Mon, 6 Jan 2020 00:28:08 -0500
Subject: [PATCH] gnu: grilo-plugins: Update to 0.3.10.
* gnu/packages/gnome.scm (grilo-plugins): Update to 0.3.10.
---
gnu/packages/gnome.scm | 47 ++++++++++++++++++------------------------
1 file changed, 20 insertions(+), 27 deletions(-)
@@ -4376,7 +4376,7 @@ for application developers.")
(define-public grilo-plugins
(package
(name "grilo-plugins")
- (version "0.3.3")
+ (version "0.3.10")
(source
(origin
(method url-fetch)
@@ -4385,39 +4385,32 @@ for application developers.")
name "-" version ".tar.xz"))
(sha256
(base32
- "172vr1y98d2mzlmg5akjn4ibrcj3gh22cwnb3cv9rvvzhj3yhrpy"))))
- (build-system gnu-build-system)
+ "0jldaixc4kzycn5v8ixkjld1n0z3dp0l1p3vchgdwpvdvc7kcfw0"))))
+ (build-system meson-build-system)
(native-inputs
- `(("glib:bin" ,glib "bin") ; for glib-mkenums and glib-genmarshal
- ("intltool" ,intltool)
- ("itstool" ,itstool)
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gtk+:bin" ,gtk+ "bin")
+ ("itstools" ,itstool)
("pkg-config" ,pkg-config)))
(inputs
- `(("grilo" ,grilo)
- ("glib" ,glib)
- ("libxml2" ,libxml2)
- ("sqlite" ,sqlite)
+ `(("gmime" ,gmime)
+ ("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
("gom" ,gom)
- ;; XXX TODO: Add oauth
- ;; XXX TODO: Add goa
- ;; XXX TODO: Add gdata (e.g. needed for youtube plugin)
- ;; XXX TODO: Add lua (needs help finding it)
+ ("grilo" ,grilo)
+ ("gssdp" ,gssdp)
+ ("gupnp" ,gupnp)
+ ("gupnp-av" ,gupnp-av)
("json-glib" ,json-glib)
- ("avahi" ,avahi)
- ("gmime" ,gmime)
+ ("libgdata" ,libgdata)
+ ("libmediaart" ,libmediaart)
+ ("librest" ,rest)
("libsoup" ,libsoup)
- ("libarchive" ,libarchive)
- ("totem-pl-parser" ,totem-pl-parser)))
+ ("totam-pl-parser" ,totem-pl-parser)
+ ("tracker" ,tracker)))
(arguments
- `(#:make-flags (list (string-append "GRL_PLUGINS_DIR="
- %output
- "/lib/grilo-"
- ,(version-major+minor version)))
- ;; XXX FIXME: Try to get the test suite working. It appears to require
- ;; a working system dbus. Inside the build container, all tests fail
- ;; with: "assertion failed: (source)". Outside of the build container,
- ;; most tests succeed.
- #:tests? #f))
+ ;;Disable lua-factory as it needs missing dependencies
+ `(#:configure-flags '("-Denable-lua-factory=no")))
(home-page "https://live.gnome.org/Grilo")
(synopsis "Plugins for the Grilo media discovery library")
(description
--
2.24.1