diff mbox series

[bug#74131] gnu: Add ruby-rfc.

Message ID 1e545625552ebc7bab7ef16f258503a07073b002.1730370347.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#74131] gnu: Add ruby-rfc. | expand

Commit Message

gemmaro Oct. 31, 2024, 10:25 a.m. UTC
* gnu/packages/ruby.scm (ruby-rfc): New variable.

Change-Id: Ib5b2e1cc3673212142e7e3e387f065ea728e9036
---
 gnu/packages/ruby.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)


base-commit: 6e50b0c56a8cc767bd3acb26638f78c450bde718
diff mbox series

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..8a26282d84 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3808,6 +3808,32 @@  (define-public ruby-fuubar
     (home-page "https://github.com/thekompanee/fuubar")
     (license license:expat)))
 
+(define-public ruby-rfc
+  (package
+    (name "ruby-rfc")
+    (version "0.2.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/p-mongodb/rfc")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0b9y63wmvypwrv5sdfwnxrzwzf59dwdb0lv9pzdj9gl0k4j21i7g"))))
+    (build-system ruby-build-system)
+    (arguments (list #:tests? #f))      ;no tests
+    (propagated-inputs (list ruby-rspec-core))
+    (synopsis
+     "RSpec formatter collection")
+    (description
+     "@samp{rfc} gem stands for RSpec Formatter Collection.  This includes a
+concise insta-failing formatter, which was originally developed for
+running large test suites in a continuous integration environment.")
+    (home-page "https://github.com/p-mongo/rfc")
+    (license license:expat)))
+
 (define-public ruby-haml
   (package
     (name "ruby-haml")