diff mbox series

[bug#53523,v7,1/2] gnu: Add tree-sitter.

Message ID 1e4edd37cfd4e6724ef6b65547da01efdf023d71.1647558246.git.luishenriquegh2701@gmail.com
State Accepted
Headers show
Series [bug#53523,v7,1/2] gnu: Add tree-sitter. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Luis Henrique Gomes Higino March 17, 2022, 11:04 p.m. UTC
* gnu/packages/text-editors.scm (tree-sitter): New variable.
---
 gnu/packages/text-editors.scm | 54 +++++++++++++++++++++++++++++++++++
 1 file changed, 54 insertions(+)


base-commit: bae2201a8ddf789dff3f625327f5b2d0a686bc77

Comments

Pierre Langlois March 25, 2022, 12:49 p.m. UTC | #1
Hi!

> * gnu/packages/text-editors.scm (tree-sitter): New variable.

I applied the patch locally and tested it, just one small nit otherwise
LGTM.  

Tested-by: Pierre Langlois <pierre.langlois@gmx.com>
Reviewed-by: Pierre Langlois <pierre.langlois@gmx.com>

Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com> writes:
> ---
>  gnu/packages/text-editors.scm | 54 +++++++++++++++++++++++++++++++++++
>  1 file changed, 54 insertions(+)
>
> diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
> index 45cc61765a..d6ec000dc6 100644
> --- a/gnu/packages/text-editors.scm
> +++ b/gnu/packages/text-editors.scm
> @@ -17,6 +17,7 @@
>  ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
>  ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
>  ;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
> +;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -39,6 +40,7 @@ (define-module (gnu packages text-editors)
>    #:use-module (guix gexp)
>    #:use-module (guix git-download)
>    #:use-module (guix utils)
> +  #:use-module (guix build utils)

I don't think you need this import right?  You'll have probably noticed
a warning:

  WARNING: (gnu packages text-editors): `which' imported from both (guix build utils) and (gnu packages base)
  
When this happens we can resolve the conflict with a prefix, so we can
have the `which' procedure and the `base::which' package.

  #:use-module ((gnu packages base) #:prefix base:)
  
In this case though we just don't need the import at all though I think.

Thanks!
Pierre
Luis Henrique Gomes Higino March 27, 2022, 10:25 p.m. UTC | #2
Pierre Langlois <pierre.langlois@gmx.com> writes:

> In this case though we just don't need the import at all though 
> I think.

You are right. I thought it was necessary to import a module 
externally to be able to use it on an origin snippet, through the 
`modules` field. However, after reading the guix manual with more 
attention, I understood it is not. Just to be sure, I tested 
building tree-sitter without this import and it was 
successful. I'll be sending the new patch series in a minute.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 45cc61765a..d6ec000dc6 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2021 Calum Irwin <calumirwin1@gmail.com>
+;;; Copyright © 2022 Luis Henrique Gomes Higino <luishenriquegh2701@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -39,6 +40,7 @@  (define-module (gnu packages text-editors)
   #:use-module (guix gexp)
   #:use-module (guix git-download)
   #:use-module (guix utils)
+  #:use-module (guix build utils)
   #:use-module (guix build-system cargo)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
@@ -62,6 +64,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages haskell-xyz)
+  #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages libreoffice)
@@ -1165,3 +1168,54 @@  (define-public virtaal
 provided by the Translate Toolkit, including XLIFF and PO.")
     (home-page "https://virtaal.translatehouse.org/")
     (license license:gpl2+)))
+
+(define-public tree-sitter
+  (package
+    (name "tree-sitter")
+    (version "0.20.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/tree-sitter/tree-sitter")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1z20518snyg0zp75qgs5bxmzjqws4dd19vnp6sya494za3qp5b6d"))
+              (modules '((guix build utils)))
+              (snippet '(begin
+                          ;; Remove bundled ICU parts
+                          (delete-file-recursively "lib/src/unicode")
+                          #t))))
+    (build-system gnu-build-system)
+    (inputs (list icu4c))
+    (arguments
+     (list #:phases
+           '(modify-phases %standard-phases
+              (delete 'configure))
+           #:tests? #f ; there are no tests for the runtime library
+           #:make-flags
+           #~(list (string-append "PREFIX="
+                                  #$output)
+                   (string-append "CC="
+                                  #$(cc-for-target)))))
+    (home-page "https://tree-sitter.github.io/tree-sitter/")
+    (synopsis "Incremental parsing system for programming tools")
+    (description
+     "Tree-sitter is a parser generator tool and an incremental parsing
+library.  It can build a concrete syntax tree for a source file and efficiently
+update the syntax tree as the source file is edited.
+
+Tree-sitter aims to be:
+
+@itemize
+@item General enough to parse any programming language
+@item Fast enough to parse on every keystroke in a text editor
+@item Robust enough to provide useful results even in the presence of syntax errors
+@item Dependency-free so that the runtime library (which is written in pure C)
+can be embedded in any application
+@end itemize
+
+This package includes the @code{libtree-sitter} runtime library.
+")
+    (license license:expat)))