diff mbox series

[bug#69674] gnu: gperftools: Fix build on riscv64-linux.

Message ID 1e4ba5cb6a6dced1527cb14604c4bd59935ddec5.1709972877.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#69674] gnu: gperftools: Fix build on riscv64-linux. | expand

Commit Message

Zheng Junjie March 9, 2024, 8:27 a.m. UTC
* gnu/packages/cpp.scm(gperftools)[arguments]: When building for riscv64-linux
always link with libatomic.

Change-Id: I067087fffd8c142759b6d113f993c3e2ab1aef9b
---
 gnu/packages/cpp.scm | 11 +++++++----
 1 file changed, 7 insertions(+), 4 deletions(-)


base-commit: a10cce5246e333be52acd7d334f59228895db89a
prerequisite-patch-id: 5a904c413bc4e5484fed86ec8a7862b20ef3156e
prerequisite-patch-id: a70182b0cf360548e7a3ae659e40c58ee3ddad71

Comments

宋文武 March 10, 2024, 3:08 a.m. UTC | #1
Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/cpp.scm(gperftools)[arguments]: When building for riscv64-linux
> always link with libatomic.

Pushed as commit b05bb6608c, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 3b65ce9f4a..d451eea2fd 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -30,7 +30,7 @@ 
 ;;; Copyright © 2022 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2022, 2023, 2024 David Elsing <david.elsing@posteo.net>
-;;; Copyright © 2022, 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2022-2024 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Antero Mejr <antero@mailbox.org>
 ;;; Copyright © 2023 Sughosha <Sughosha@proton.me>
@@ -907,9 +907,12 @@  (define-public gperftools
        (file-name (git-file-name name version))))
     (build-system gnu-build-system)
     (arguments
-      ;; The tests are flaky when run in parallel. For more info:
-      ;; https://bugs.gnu.org/46562
-     '(#:parallel-tests? #f))
+     ;; The tests are flaky when run in parallel. For more info:
+     ;; https://bugs.gnu.org/46562
+     `(#:parallel-tests? #f
+       ,@(if (target-riscv64?)
+             `(#:make-flags (list "LDFLAGS=-latomic"))
+             '())))
     (native-inputs
      (list autoconf automake libtool
            ;; For tests.