diff mbox series

[bug#74238] gnu: liblouisutdml: Update to 2.12.0-0.00ca783.

Message ID 1e3cb639f5828c8caa34497da0ce313337a4b994.1730977666.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series [bug#74238] gnu: liblouisutdml: Update to 2.12.0-0.00ca783. | expand

Commit Message

Z572 Nov. 7, 2024, 11:07 a.m. UTC
* gnu/packages/language.scm (liblouisutdml): Update to 2.12.0-0.00ca783.
[arguments]: Use G-expressions.
[native-inputs]: Remove labels.
[propagated-inputs]: Remove labels.

Change-Id: Iedbcb5b3073f26a42805ae02550a28f6f1abee86
---
 gnu/packages/language.scm | 76 ++++++++++++++++++++-------------------
 1 file changed, 40 insertions(+), 36 deletions(-)


base-commit: fea85206275f28108cc9cfbce7b2e0d1147abd1e

Comments

Maxim Cournoyer Nov. 11, 2024, 8:39 a.m. UTC | #1
Hello!

Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:

> * gnu/packages/language.scm (liblouisutdml): Update to 2.12.0-0.00ca783.
> [arguments]: Use G-expressions.
> [native-inputs]: Remove labels.
> [propagated-inputs]: Remove labels.
>
> Change-Id: Iedbcb5b3073f26a42805ae02550a28f6f1abee86
> ---
>  gnu/packages/language.scm | 76 ++++++++++++++++++++-------------------
>  1 file changed, 40 insertions(+), 36 deletions(-)
>
> diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
> index 71e9ae2511..e00e30b7dc 100644
> --- a/gnu/packages/language.scm
> +++ b/gnu/packages/language.scm
> @@ -11,6 +11,7 @@
>  ;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
>  ;;; Copyright © 2024 Charles <charles@charje.net>
>  ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
> +;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -386,45 +387,48 @@ (define-public liblouis
>                     license:gpl3+))))    ; tools
>  
>  (define-public liblouisutdml
> -  (package
> -    (name "liblouisutdml")
> -    (version "2.9.0")
> -    (source
> -     (origin
> -       (method git-fetch)
> -       (uri
> -        (git-reference
> -         (url "https://github.com/liblouis/liblouisutdml")
> -         (commit (string-append "v" version))))
> -       (file-name (git-file-name name version))
> -       (sha256
> -        (base32 "0c32cfcfp0lyfd655c9ihhh3p7lhrb9q3xbll7q5dw4km86gaq6w"))))
> -    (build-system gnu-build-system)
> -    (outputs '("out" "bin" "doc"))
> -    (arguments
> -     `(#:configure-flags
> -       (list "--disable-static")))
> -    (native-inputs
> -     `(("autoconf" ,autoconf)
> -       ("automake" ,automake)
> -       ("help2man" ,help2man)
> -       ("jdk" ,icedtea "jdk")
> -       ("libtool" ,libtool)
> -       ("makeinfo" ,texinfo)
> -       ("pkg-config" ,pkg-config)))
> -    (inputs
> -     (list libxml2))
> -    (propagated-inputs
> -     `(("liblouis" ,liblouis)
> -       ("liblouis:bin" ,liblouis "bin")))
> -    (synopsis "Braille transcription services")
> -    (description "Liblouisutdml is a library providing complete braille
> +  ;; The new version fixes the test, but not release.

I'd instead word the above like: "Use the latest commit, which includes
test suite fixes not yet released."

> +  (let ((commit "00ca7838e30ebd5ed6f635236aa235e2c8f089c1")
> +        (revision "0"))
> +    (package
> +      (name "liblouisutdml")
> +      (version (git-version "2.12.0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri
> +          (git-reference
> +           (url "https://github.com/liblouis/liblouisutdml")
> +           (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1pr3wys48bzblr6kav24gr8slsp409f81iqxw19922k24y5y31l7"))))
> +      (build-system gnu-build-system)
> +      (outputs '("out" "bin" "doc"))
> +      (arguments
> +       (list #:configure-flags
> +             #~(list "--disable-static")))
> +      (native-inputs
> +       (list autoconf
> +             automake
> +             help2man
> +             `(,icedtea "jdk")
> +             libtool
> +             texinfo
> +             pkg-config))
> +      (inputs
> +       (list libxml2))
> +      (propagated-inputs
> +       (list liblouis
> +             `(,liblouis "bin")))
> +      (synopsis "Braille transcription services")
> +      (description "Liblouisutdml is a library providing complete braille
>  transcription services for xml, html and text documents.  It translates into
>  appropriate braille codes and formats according to its style sheet and the
>  specifications in the document.")
> -    (home-page "http://liblouis.org/")
> -    (license (list license:lgpl3+       ; library
> -                   license:gpl3+))))    ; tools
> +      (home-page "http://liblouis.org/")
> +      (license (list license:lgpl3+       ; library
> +                     license:gpl3+)))))    ; tools

Otherwise, LGTM, thanks for the fix.

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
Z572 Nov. 12, 2024, 4:21 a.m. UTC | #2
Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello!
>
> Zheng Junjie <zhengjunjie@iscas.ac.cn> writes:
>
>> * gnu/packages/language.scm (liblouisutdml): Update to 2.12.0-0.00ca783.
>> [arguments]: Use G-expressions.
>> [native-inputs]: Remove labels.
>> [propagated-inputs]: Remove labels.
>>
>> Change-Id: Iedbcb5b3073f26a42805ae02550a28f6f1abee86
>> ---
>>  gnu/packages/language.scm | 76 ++++++++++++++++++++-------------------
>>  1 file changed, 40 insertions(+), 36 deletions(-)
>>
>> diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
>> index 71e9ae2511..e00e30b7dc 100644
>> --- a/gnu/packages/language.scm
>> +++ b/gnu/packages/language.scm
>> @@ -11,6 +11,7 @@
>>  ;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
>>  ;;; Copyright © 2024 Charles <charles@charje.net>
>>  ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
>> +;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
>>  ;;;
>>  ;;; This file is part of GNU Guix.
>>  ;;;
>> @@ -386,45 +387,48 @@ (define-public liblouis
>>                     license:gpl3+))))    ; tools
>>  
>>  (define-public liblouisutdml
>> -  (package
>> -    (name "liblouisutdml")
>> -    (version "2.9.0")
>> -    (source
>> -     (origin
>> -       (method git-fetch)
>> -       (uri
>> -        (git-reference
>> -         (url "https://github.com/liblouis/liblouisutdml")
>> -         (commit (string-append "v" version))))
>> -       (file-name (git-file-name name version))
>> -       (sha256
>> -        (base32 "0c32cfcfp0lyfd655c9ihhh3p7lhrb9q3xbll7q5dw4km86gaq6w"))))
>> -    (build-system gnu-build-system)
>> -    (outputs '("out" "bin" "doc"))
>> -    (arguments
>> -     `(#:configure-flags
>> -       (list "--disable-static")))
>> -    (native-inputs
>> -     `(("autoconf" ,autoconf)
>> -       ("automake" ,automake)
>> -       ("help2man" ,help2man)
>> -       ("jdk" ,icedtea "jdk")
>> -       ("libtool" ,libtool)
>> -       ("makeinfo" ,texinfo)
>> -       ("pkg-config" ,pkg-config)))
>> -    (inputs
>> -     (list libxml2))
>> -    (propagated-inputs
>> -     `(("liblouis" ,liblouis)
>> -       ("liblouis:bin" ,liblouis "bin")))
>> -    (synopsis "Braille transcription services")
>> -    (description "Liblouisutdml is a library providing complete braille
>> +  ;; The new version fixes the test, but not release.
>
> I'd instead word the above like: "Use the latest commit, which includes
> test suite fixes not yet released."
>
>> +  (let ((commit "00ca7838e30ebd5ed6f635236aa235e2c8f089c1")
>> +        (revision "0"))
>> +    (package
>> +      (name "liblouisutdml")
>> +      (version (git-version "2.12.0" revision commit))
>> +      (source
>> +       (origin
>> +         (method git-fetch)
>> +         (uri
>> +          (git-reference
>> +           (url "https://github.com/liblouis/liblouisutdml")
>> +           (commit commit)))
>> +         (file-name (git-file-name name version))
>> +         (sha256
>> +          (base32 "1pr3wys48bzblr6kav24gr8slsp409f81iqxw19922k24y5y31l7"))))
>> +      (build-system gnu-build-system)
>> +      (outputs '("out" "bin" "doc"))
>> +      (arguments
>> +       (list #:configure-flags
>> +             #~(list "--disable-static")))
>> +      (native-inputs
>> +       (list autoconf
>> +             automake
>> +             help2man
>> +             `(,icedtea "jdk")
>> +             libtool
>> +             texinfo
>> +             pkg-config))
>> +      (inputs
>> +       (list libxml2))
>> +      (propagated-inputs
>> +       (list liblouis
>> +             `(,liblouis "bin")))
>> +      (synopsis "Braille transcription services")
>> +      (description "Liblouisutdml is a library providing complete braille
>>  transcription services for xml, html and text documents.  It translates into
>>  appropriate braille codes and formats according to its style sheet and the
>>  specifications in the document.")
>> -    (home-page "http://liblouis.org/")
>> -    (license (list license:lgpl3+       ; library
>> -                   license:gpl3+))))    ; tools
>> +      (home-page "http://liblouis.org/")
>> +      (license (list license:lgpl3+       ; library
>> +                     license:gpl3+)))))    ; tools
>
> Otherwise, LGTM, thanks for the fix.
>
> Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>
thanks!

push, close.
Maxim Cournoyer Nov. 12, 2024, 12:24 p.m. UTC | #3
Hi Zheng!

Z572 <zhengjunjie@iscas.ac.cn> writes:

[...]

> thanks!
>
> push, close.

Excellent.  English nitpick, if I may, for your 'merge' replies:

'Pushed, closing.'

Take it with a grain of salt as I'm no English native either :-).

Cheers!
diff mbox series

Patch

diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index 71e9ae2511..e00e30b7dc 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2024 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2024 Charles <charles@charje.net>
 ;;; Copyright © 2024 Nicolas Graves <ngraves@ngraves.fr>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -386,45 +387,48 @@  (define-public liblouis
                    license:gpl3+))))    ; tools
 
 (define-public liblouisutdml
-  (package
-    (name "liblouisutdml")
-    (version "2.9.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri
-        (git-reference
-         (url "https://github.com/liblouis/liblouisutdml")
-         (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0c32cfcfp0lyfd655c9ihhh3p7lhrb9q3xbll7q5dw4km86gaq6w"))))
-    (build-system gnu-build-system)
-    (outputs '("out" "bin" "doc"))
-    (arguments
-     `(#:configure-flags
-       (list "--disable-static")))
-    (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("help2man" ,help2man)
-       ("jdk" ,icedtea "jdk")
-       ("libtool" ,libtool)
-       ("makeinfo" ,texinfo)
-       ("pkg-config" ,pkg-config)))
-    (inputs
-     (list libxml2))
-    (propagated-inputs
-     `(("liblouis" ,liblouis)
-       ("liblouis:bin" ,liblouis "bin")))
-    (synopsis "Braille transcription services")
-    (description "Liblouisutdml is a library providing complete braille
+  ;; The new version fixes the test, but not release.
+  (let ((commit "00ca7838e30ebd5ed6f635236aa235e2c8f089c1")
+        (revision "0"))
+    (package
+      (name "liblouisutdml")
+      (version (git-version "2.12.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/liblouis/liblouisutdml")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1pr3wys48bzblr6kav24gr8slsp409f81iqxw19922k24y5y31l7"))))
+      (build-system gnu-build-system)
+      (outputs '("out" "bin" "doc"))
+      (arguments
+       (list #:configure-flags
+             #~(list "--disable-static")))
+      (native-inputs
+       (list autoconf
+             automake
+             help2man
+             `(,icedtea "jdk")
+             libtool
+             texinfo
+             pkg-config))
+      (inputs
+       (list libxml2))
+      (propagated-inputs
+       (list liblouis
+             `(,liblouis "bin")))
+      (synopsis "Braille transcription services")
+      (description "Liblouisutdml is a library providing complete braille
 transcription services for xml, html and text documents.  It translates into
 appropriate braille codes and formats according to its style sheet and the
 specifications in the document.")
-    (home-page "http://liblouis.org/")
-    (license (list license:lgpl3+       ; library
-                   license:gpl3+))))    ; tools
+      (home-page "http://liblouis.org/")
+      (license (list license:lgpl3+       ; library
+                     license:gpl3+)))))    ; tools
 
 (define-public libstemmer
   (package