diff mbox series

[bug#70057] gnu: Add python-apprise.

Message ID 1e2f0580212adc76b9fe6479c45414c094effc64.1711642451.git.me@fabionatali.com
State New
Headers show
Series [bug#70057] gnu: Add python-apprise. | expand

Commit Message

Fabio Natali March 28, 2024, 4:15 p.m. UTC
* gnu/packages/python-xyz.scm (python-apprise): New variable.

Change-Id: I55b8c7b558ce34835cff31b9fac6ff3b81ff5fec
---
Hi! 👋

This is to add Apprise, a push notification Python library.

It seems that Apprise is required if we want to upgrade borgmatic from 1.7.12 to 1.8.9.

I hope the patch looks alright but all feedback is welcome.

Thanks, cheers, Fabio.

 gnu/packages/python-xyz.scm | 46 +++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: fb9549164520ad993c2fbbaedc899844d57baabc

Comments

jgart March 29, 2024, 5:09 p.m. UTC | #1
Hi Fabio,

Thanks for the patch and your contribution to GNU Guix. I reviewed and applied python-apprise.

I'll take a look at your other patch for borgmatic soon.

all the best,

jgart
jgart March 31, 2024, 10:51 p.m. UTC | #2
Hi Fabio,

I reviewed and applied borgmatic with some minor changes.

I consolidated the propagated-inputs to be part of the inputs as it was in the previous existing package. 

Since borgmatic is an end user application we do not need to propagate the Python library dependencies.

I also applied guix style to the package which introduced some formatting changes and mentioned the changes in the commit message.

all the best,

jgart
jgart March 31, 2024, 10:52 p.m. UTC | #3
Hi Fabio,

I reviewed and applied borgmatic with some minor changes.

I consolidated the propagated-inputs to be part of the inputs as it was in the previous existing package. 
h
Since borgmatic is an end user application we do not need to propagate the Python library dependencies.

I also applied guix style to the package which introduced some formatting changes and mentioned the changes in the commit message.

all the best,

jgart
jgart March 31, 2024, 11:23 p.m. UTC | #4
Hi Fabio,

I reviewed and applied borgmatic with some minor changes.

I consolidated the propagated-inputs to be part of the inputs as it was in the previous existing package. 

Since borgmatic is an end user application we do not need to propagate the Python library dependencies.

I also applied guix style to the package which introduced some formatting changes and mentioned the changes in the commit message.

all the best,

jgart
Fabio Natali April 1, 2024, 10:24 a.m. UTC | #5
On 2024-03-31, 23:23 +0000, "jgart" <jgart@dismail.de> wrote:
> I reviewed and applied borgmatic with some minor changes.

This is brilliant, thanks for helping with this jgart!

Have a lovely day. Cheers, Fabio.
jgart April 1, 2024, 3:55 p.m. UTC | #6
> This is brilliant, thanks for helping with this jgart!
> 
> Have a lovely day. Cheers, Fabio.

Anytime! Excuse the duplicate emails. My email client was acting up.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8a6ef23b58..2cdcc5e51c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -231,6 +231,7 @@  (define-module (gnu packages python-xyz)
   #:use-module (gnu packages man)
   #:use-module (gnu packages markup)
   #:use-module (gnu packages maths)
+  #:use-module (gnu packages messaging)
   #:use-module (gnu packages monitoring)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
@@ -293,6 +294,51 @@  (define-module (gnu packages python-xyz)
   #:use-module (srfi srfi-1)
   #:use-module (srfi srfi-26))
 
+(define-public python-apprise
+  (package
+    (name "python-apprise")
+    (version "1.7.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "apprise" version))
+       (sha256
+        (base32 "0wvs1k71fipn617y9wsdcvwcgg2pd0nvriarlwl4438la4086ppg"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-certifi
+                             python-click
+                             python-dataclasses
+                             python-markdown
+                             python-pyyaml
+                             python-requests
+                             python-requests-oauthlib))
+    (native-inputs (list python-babel
+                         python-coverage
+                         python-cryptography
+                         python-flake8
+                         python-paho-mqtt
+                         python-pytest
+                         python-pytest-cov
+                         python-pytest-mock
+                         python-pytest-xdist
+                         python-wheel))
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   (replace 'check
+                     (lambda* (#:key tests? inputs outputs #:allow-other-keys)
+                       (when tests?
+                         (delete-file "test/test_plugin_macosx.py")
+                         (invoke "pytest")))))))
+    (home-page "https://github.com/caronc/apprise")
+    (synopsis
+     "Push notification Python library that works with many platforms")
+    (description
+     "Apprise is a Python library that allows sending push notifications to a broad
+range of notification services, such as Telegram, Discord, Slack, Amazon SNS,
+Gotify, etc.")
+    (license license:bsd-2)))
+
 (define-public python-xmldiff
   (package
     (name "python-xmldiff")