[bug#71327,8/8] gnu: udisks: Remove obsolete wrap-udisksd phase.
Commit Message
The tools are now patched in the libblockdev plugin sources directly.
* gnu/packages/freedesktop.scm (udisks) [phases]: Delete the wrap-udisksd
phase.
Change-Id: I0de4016adb0cb8af2dca4ef9ebec82e5951b689c
---
gnu/packages/freedesktop.scm | 17 +----------------
1 file changed, 1 insertion(+), 16 deletions(-)
@@ -1789,22 +1789,7 @@ (define-public udisks
(("girdir = .*")
"girdir = $(datadir)/gir-1.0\n")
(("typelibsdir = .*")
- "typelibsdir = $(libdir)/girepository-1.0\n"))))
- (add-after 'install 'wrap-udisksd
- (lambda* (#:key outputs inputs #:allow-other-keys)
- ;; Tell 'udisksd' where to find the 'mount' command.
- (let ((out (assoc-ref outputs "out"))
- (utils (assoc-ref inputs "util-linux"))
- (cryptsetup (assoc-ref inputs "cryptsetup"))
- (parted (assoc-ref inputs "parted")))
- (wrap-program (string-append out "/libexec/udisks2/udisksd")
- `("PATH" ":" prefix
- (,(string-append utils "/bin") ;for 'mount'
- ;; cryptsetup is required for setting encrypted
- ;; partitions, e.g. in gnome-disks
- ,(string-append cryptsetup "/sbin")
- "/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))))))))
+ "typelibsdir = $(libdir)/girepository-1.0\n")))))))
(home-page "https://www.freedesktop.org/wiki/Software/udisks/")
(synopsis "Disk manager service")
(description