diff mbox series

[bug#71433,1/6] gnu: Add go-github-com-elgris-jsondiff.

Message ID 1e125502a012a08f1a39ea1351dd103fce03f0c3.1717846795.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: kubo: Unbundle more Go packages. | expand

Commit Message

Artyom V. Poptsov June 8, 2024, 11:44 a.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-elgris-jsondiff): New variable.

Change-Id: I88b31572f04079aaae24555163c67e09cd6dfec1
---
 gnu/packages/golang-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b869b39e3..cc417b2c24 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1222,6 +1222,33 @@  (define-public go-github-com-dustin-gojson
 scanner API made public.")
     (license license:bsd-3)))
 
+(define-public go-github-com-elgris-jsondiff
+  (package
+    (name "go-github-com-elgris-jsondiff")
+    (version "v0.0.0-20160530203242-765b5c24c302")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/elgris/jsondiff")
+             (commit (go-version->git-ref version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0jm1q0s531hmkqdx8jqphfpmzysn44aphkpwlzqwp3hkz89g4d4q"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:go go-1.21
+           #:import-path "github.com/elgris/jsondiff"))
+    (native-inputs
+     (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-mgutz-ansi))
+    (home-page "https://github.com/elgris/jsondiff")
+    (synopsis "Produce readable diff of 2 JSON-able objects")
+    (description
+     "@code{jsondiff} produces readable diff of 2 JSON-able (read \"convertible to
+map[string]interface{}\") objects.  Useful for diagnostics or debugging.")
+    (license license:expat)))
+
 (define-public go-github-com-elliotchance-orderedmap
   (package
     (name "go-github-com-elliotchance-orderedmap")