diff mbox series

[bug#74411,v2,4/5] gnu: Add freedict-dictionaries.

Message ID 1dcd87131c679a4d7e80d9d4c9c44807fb00cf0a.1732150157.git.runciter@whispers-vpn.org
State New
Headers show
Series [bug#74411,v2,1/5] gnu: Add (gnu packages dictd). | expand

Commit Message

Runciter Nov. 21, 2024, 12:50 a.m. UTC
* gnu/packages/dictionaries (freedict-dictionaries): New variable.

Signed-off-by: Runciter <runciter@whispers-vpn.org>
---
 gnu/packages/dictionaries.scm | 48 +++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/dictionaries.scm b/gnu/packages/dictionaries.scm
index 3470d8d945..3e5d991890 100644
--- a/gnu/packages/dictionaries.scm
+++ b/gnu/packages/dictionaries.scm
@@ -9,6 +9,7 @@ 
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2020 Lu hux <luhux@outlook.com>
 ;;; Copyright © 2022 ROCKTAKEY <rocktakey@gmail.com>
+;;; Copyright © 2022 Runciter <runciter@whispers-vpn.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -519,3 +520,50 @@  (define-public freedict-tools-0.6.0
 Guix package is installed.")
     (home-page "https://freedict.org")
     (license license:gpl2+)))
+
+(define-public freedict-dictionaries
+  (package
+    (name "freedict-dictionaries")
+    (version "914b5f7")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/freedict/fd-dictionaries")
+             (commit "914b5f754b695e9422bf951837b0682a077e244e")))
+       (sha256
+        (base32 "0a8k5rq94rl1nmz0354sx2gmyqica0yjavirh5v5wdybkfq8nv83"))))
+    (inputs (list espeak-ng
+                  python
+                  perl
+                  gzip
+                  tar
+                  libxslt
+                  dictd-1.13.1
+                  perl-libxml
+                  freedict-tools-0.6.0))
+    (arguments
+     (list
+      #:tests? #f
+      #:make-flags #~(list (string-append "PREFIX="
+                                          #$output))
+      #:phases #~(modify-phases %standard-phases
+                   (delete 'configure)
+                   (add-before 'build 'set-tools-prefix-in-makefile
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (substitute* "Makefile"
+                         (("FREEDICT_TOOLS \\?= ../tools")
+                          (string-append "export FREEDICT_TOOLS = "
+                                         #$(file-append
+                                            freedict-tools-0.6.0
+                                            "/share/freedict")))))))))
+    (build-system gnu-build-system)
+    (synopsis "Freedict multilingual dictionaries compiled to the dictd
+format")
+    (description
+     "FreeDict is a project that offers over 140 free
+ dictionaries in about 45 languages, with the right to study, change and
+ modify them.  You can use them offline on your computer or mobile phone
+ and export them to any format and application.")
+    (home-page "https://freedict.org")
+    (license license:gpl2+)))