diff mbox series

[bug#64286] gnu: Add python-beziers.

Message ID 1d8f2bcf3bb3fd9c63f1deed4e4445c0420943c6.1687717785.git.hrn@posteo.net
State New
Headers show
Series [bug#64286] gnu: Add python-beziers. | expand

Commit Message

hrn June 25, 2023, 6:46 p.m. UTC
---
 gnu/packages/fontutils.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Ludovic Courtès Oct. 8, 2023, 9:34 p.m. UTC | #1
Hi,

Rikard Nordgren <hrn@posteo.net> skribis:

> +(define-public python-beziers
> +  (package
> +    (name "python-beziers")

Finally applied (I added a commit log), thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 1b4e0064f4..61c4074603 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -357,6 +357,37 @@  (define-public python-afdko-3.6.1
            python-ufonormalizer
            python-ufoprocessor))))
 
+(define-public python-beziers
+  (package
+    (name "python-beziers")
+    (version "0.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/simoncozens/beziers.py")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1dyr45m15sclbgaz1mrcnw8kny50h09gd45dlpfkgv9qpfxphkg3"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda* (#:key tests? #:allow-other-keys)
+                            (when tests?
+                              (invoke "pytest" "-vv")))))))
+    (native-inputs (list python-pytest python-dotmap python-matplotlib))
+    (propagated-inputs (list python-pyclipper))
+    (home-page "https://simoncozens.github.io/beziers.py/index.html")
+    (synopsis "Python bezier manipulation library")
+    (description
+     "Beziers provides a variety of classes for constructing,
+manipulating and drawing Bezier curves and paths.  Principally designed for
+font design software, it allows you to join, split, offset, and perform many
+other operations on paths.")
+    (license license:expat)))
+
 (define-public python-cffsubr
   (package
     (name "python-cffsubr")