diff mbox series

[bug#68462] gnu: Add emacs-plan9-theme.

Message ID 1cad23a76cf90c95c1b0672f6d0d9abd6cc73a71.1705276359.git.suhail@bayesians.ca
State New
Headers show
Series [bug#68462] gnu: Add emacs-plan9-theme. | expand

Commit Message

Suhail Jan. 14, 2024, 11:59 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-plan9-theme): New variable.

Change-Id: I6053ce66cfceca5a34d0dfd55691be9346f3a916
---
 gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)


base-commit: f2102cb5b9239be2ed2023b908b726af542e0124

Comments

Suhail Feb. 16, 2024, 4:44 a.m. UTC | #1
Bumping this.  In case a potential reviewer sees this, this may well be
a relatively simple patch to review (new package with no dependencies).
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a24f4a106..89b6f10de0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33771,6 +33771,27 @@  (define-public emacs-modus-themes
     (license (list license:gpl3+
                    license:fdl1.3+)))) ; GFDLv1.3+ for the manual
 
+(define-public emacs-plan9-theme
+  (package
+    (name "emacs-plan9-theme")
+    (version "0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/john2x/plan9-theme.el")
+             (commit "c2da2fcb241e9800d931a1ff19ecd9fd84d30382")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0rjxbk9fljnjmg00vdqcyynzg591cgknyy2d92xsxsyg4d28dvwi"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/john2x/plan9-theme.el")
+    (synopsis "Light color theme for Emacs based on Plan 9")
+    (description
+     "@code{plan9} is an Emacs theme with light colors and a classic
+look which is inspired by the colors of Plan 9 from Bell Labs.")
+    (license license:gpl3+)))
+
 (define-public emacs-punpun-theme
   (let ((commit "7026684cd568cb691af3ced5de14c375fe6f5a1a")
         (revision "0"))