diff mbox series

[bug#71615] Split out picocss from Mumi.

Message ID 1c7c0942bfd3d5f4e690456384d84d29e887cffe.1718644021.git.felix.lechner@lease-up.com
State New
Headers show
Series [bug#71615] Split out picocss from Mumi. | expand

Commit Message

Felix Lechner June 17, 2024, 5:09 p.m. UTC
The inclusion of Picocss an inline function in Mumi may not meet project
standards.  For example, Picocss is probably not captured as a prerequisite of
software we use; its license is not tracked; and its sources are not backed up
by the Software Heritage archive.

Change-Id: I447aa8d0c34376f5a55dce596f19d956622a5ecf
---
 gnu/packages/mail.scm | 15 +++++----------
 gnu/packages/web.scm  | 22 ++++++++++++++++++++++
 2 files changed, 27 insertions(+), 10 deletions(-)


base-commit: 71c678a16aae416298a0e3fa322b425315bb7b00

Comments

Arun Isaac June 17, 2024, 9:29 p.m. UTC | #1
Hi Felix,

Good point! We should do this. Some comments follow.

It would be good to split this into two separate commits—one adding
picocss, and the other using it in mumi. I will send a v2 patchset where
I have done this.

Also, we should decide on some directory structure for CSS packages like
picocss, similar to how we have a standardized directory structure for
our font packages. Simply copying the entire source tree copies over too
many unnecessary files.

Maybe prefix CSS packages with css-. So, css-picocss instead of
picocss. May also be an idea to put CSS packages in a separate file
gnu/packages/css.scm.

Thanks,
Arun
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d853fab4d3..5c4f688f3b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4226,16 +4226,11 @@  (define-public mumi
            mailutils
            xdg-utils))
     (native-inputs
-     (list autoconf automake pkg-config sassc
-           (origin
-             (method git-fetch)
-             (uri (git-reference
-                   (url "https://github.com/picocss/pico.git")
-                   (commit "3052db4bd3439e236479dc0f98069f7d3b559486")))
-             (file-name (git-file-name "pico" "1.5.6"))
-             (sha256
-              (base32
-               "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi")))))
+     (list autoconf
+           automake
+           pkg-config
+           picocss
+           sassc))
     (home-page "https://git.savannah.gnu.org/cgit/guix/mumi.git/")
     (synopsis "Debbugs web interface")
     (description "Mumi is a Debbugs web interface.")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b9991bb9c1..bf688b2f6f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5064,6 +5064,28 @@  (define-public perl-www-robotrules
 their web site.")
     (home-page "https://metacpan.org/release/WWW-RobotRules")))
 
+(define-public picocss
+  (package
+    (name "picocss")
+    (version "1.5.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/picocss/pico.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi"))))
+    (build-system copy-build-system)
+    (home-page "https://picocss.com/")
+    (synopsis "Minimal CSS Framework for Semantic HTML")
+    (description "A minimalist and lightweight starter kit that prioritizes
+semantic syntax, making every HTML element responsive and elegant by default.
+Pico CSS can be used without custom CSS but it was designed as a CSS starting
+point.")
+    (license license:expat)))
+
 (define-public python-lambda-4dn
   (package
     (name "python-lambda-4dn")