[bug#74982] gnu: python-cheroot: Update to 10.0.1.

Message ID 1c7913f4f0361fbe86a31dc9bf79c580c55c4a8c.1734646286.git.sarg@sarg.org.ru
State New
Headers
Series [bug#74982] gnu: python-cheroot: Update to 10.0.1. |

Commit Message

Sergey Trofimov Dec. 19, 2024, 10:11 p.m. UTC
  * gnu/packages/python-web.scm (python-cheroot): Update to 10.0.1.
[native-inputs]: New test dependencies.
[propagated-inputs]: Remove python-six.
---
 gnu/packages/python-web.scm | 27 ++++++++++++++-------------
 1 file changed, 14 insertions(+), 13 deletions(-)


base-commit: 07b4b1d055c36c6c61d39273c26974771dbfe805
--
2.46.0
  

Comments

jgart Dec. 24, 2024, 5:54 p.m. UTC | #1
Thanks for your contribution. Applied.
  

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a14db7bd9f..c97f2b3ce6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1402,14 +1402,14 @@  (define-public python-httplib2
 (define-public python-cheroot
   (package
     (name "python-cheroot")
-    (version "10.0.0")
+    (version "10.0.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "cheroot" version))
        (sha256
         (base32
-         "1w0ind0dza9j1py56y23344piqkpyfmcm060qfrnk6gggy3s3i2r"))))
+         "0h0p3fnpa4dxi589s7ljlzb6p3mhqdivb3pc2f36pljqfrwjzf70"))))
     (build-system pyproject-build-system)
     (arguments
      (list
@@ -1419,8 +1419,13 @@  (define-public python-cheroot
               ;; "--numprocesses=auto"
               "--doctest-modules"
               "--showlocals"
-              ;; Disable test requiring networking.
-              "-k" "not test_tls_client_auth")
+              "-k" (string-append
+                    ;; Disable test requiring networking.
+                    "not test_tls_client_auth"
+                    ;; TypeError: HTTPConnection.request() got an unexpected keyword
+                    ;; argument 'chunked'
+                    " and not test_peercreds_unix_sock"
+                    " and not test_peercreds_unix_sock_with_lookup"))
       #:phases
       #~(modify-phases %standard-phases
           (replace 'check
@@ -1430,25 +1435,21 @@  (define-public python-cheroot
                   (apply invoke "pytest" "-v"
                          (append test-flags (list #$output))))))))))
     (propagated-inputs
-     (list python-jaraco-functools
-           python-more-itertools
-           python-six))
+     (list python-jaraco-functools python-more-itertools))
     (native-inputs
-     (list python-cryptography
-           python-jaraco-text
+     (list python-jaraco-text
            python-portend
            python-pyopenssl
            python-pypytools
-           python-pytest
            python-pytest-cov
            python-pytest-mock
-           python-pytest-xdist
            python-requests
            python-requests-toolbelt
            python-requests-unixsocket
+           python-setuptools
            python-setuptools-scm
-           python-setuptools-scm-git-archive
-           python-trustme))
+           python-trustme
+           python-wheel))
     (home-page "https://cheroot.cherrypy.dev")
     (synopsis "Highly-optimized, pure-python HTTP server")
     (description