[bug#77087] gnu: emacs-chatgpt-shell: Update to 2.16.1.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-chatgpt-shell): Update to 2.16.1.
Change-Id: Ie27454e83b8b93c85485c099c490fcab7b320aa6
---
- update
- activate tests
gnu/packages/emacs-xyz.scm | 13 +++++++++----
1 file changed, 9 insertions(+), 4 deletions(-)
base-commit: 11eb2c0ffc9a08166ec8cb8874e323bba2e74557
--
2.48.1
@@ -644,7 +644,7 @@ (define-public emacs-gptel-quick
(define-public emacs-chatgpt-shell
(package
(name "emacs-chatgpt-shell")
- (version "2.13.1")
+ (version "2.16.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -653,19 +653,24 @@ (define-public emacs-chatgpt-shell
(file-name (git-file-name name version))
(sha256
(base32
- "1vlvwim1v14cvd4w3bd10xfzaw3mhsiv5qh4ka67jgninq8kjls5"))))
+ "1xq4hfr3m5sgi9wrr3nrp6fsnnw8d044gz0y50d4h46cvq8c6f2g"))))
(build-system emacs-build-system)
(arguments
(list #:phases
#~(modify-phases %standard-phases
;; This phase prevents build phase failure.
- (add-before 'build 'generate-empty-config-file
+ (add-after 'unpack 'generate-empty-config-file
(lambda _
(setenv "HOME" (getcwd))
(mkdir-p ".emacs.d")
(call-with-output-file ".emacs.d/.chatgpt-shell.el"
(lambda (port)
- (display "nil" port))))))))
+ (display "nil" port))))))
+ #:tests? #t
+ #:test-command #~(list "emacs" "-Q" "--batch"
+ "-l" "test_chatgpt-shell.el"
+ "-l" "chatgpt-shell.el"
+ "-f" "ert-run-tests-batch-and-exit")))
(propagated-inputs (list emacs-shell-maker))
(home-page "https://github.com/xenodium/chatgpt-shell")
(synopsis "ChatGPT and DALL-E Emacs shells and Org Babel libraries")