diff mbox series

[bug#68005] gnu: Remove dxvk.

Message ID 1c689ee56afaafdc94806917952535e74b2a2ba8.1703432060.git.kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#68005] gnu: Remove dxvk. | expand

Commit Message

Kaelyn Takata Dec. 24, 2023, 3:35 p.m. UTC
This package has been broken for some time, and upstream removed support for
building with winelib in version 1.7 released in May 2020.

* gnu/packages/wine.scm (dxvk): Delete variable.

Change-Id: I393853aa6e0c9257907549f346a36a1fe37a61a0
---
 gnu/packages/wine.scm | 84 -------------------------------------------
 1 file changed, 84 deletions(-)


base-commit: 0d13d095420861022e68e87ceebd5e037e12a8b3
diff mbox series

Patch

diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 400f0e7607..5cbed406aa 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -425,87 +425,3 @@  (define-public wine64-staging
     (synopsis "Implementation of the Windows API (staging branch, WoW64
 version)")
     (supported-systems '("x86_64-linux" "aarch64-linux"))))
-
-(define dxvk32
-  ;; This package provides 32-bit dxvk libraries on 64-bit systems.
-  (package
-    (name "dxvk32")
-    (version "1.5.5")
-    (home-page "https://github.com/doitsujin/dxvk/")
-    (source (origin
-              (method git-fetch)
-              (uri (git-reference
-                    (url home-page)
-                    (commit (string-append "v" version))))
-              (file-name (git-file-name name version))
-              (sha256
-               (base32
-                "1inl0qswgvbp0fs76md86ilqf9mbshkpjm8ga81khn9zd6v3fvan"))))
-    (build-system meson-build-system)
-    (arguments
-     `(#:system "i686-linux"
-       #:configure-flags (list "--cross-file"
-                               (string-append (assoc-ref %build-inputs "source")
-                                              "/build-wine32.txt"))))
-    (native-inputs
-     `(("glslang" ,glslang)))
-    (inputs
-     `(("wine" ,wine-staging)))
-    (synopsis "Vulkan-based D3D9, D3D10 and D3D11 implementation for Wine")
-    (description "A Vulkan-based translation layer for Direct3D 9/10/11 which
-allows running complex 3D applications with high performance using Wine.
-
-Use @command{setup_dxvk} to install the required libraries to a Wine prefix.")
-    (supported-systems '("x86_64-linux"))
-    (license license:zlib)))
-
-(define-public dxvk
-  (package
-    (inherit dxvk32)
-    (name "dxvk")
-    (arguments
-     `(#:configure-flags (list "--cross-file"
-                               (string-append (assoc-ref %build-inputs "source")
-                                              "/build-wine"
-                                              ,(match (%current-system)
-                                                 ("x86_64-linux" "64")
-                                                 (_ "32"))
-                                              ".txt"))
-       #:phases
-       (modify-phases %standard-phases
-         ,@(if (string=? (%current-system) "x86_64-linux")
-             `((add-after 'unpack 'install-32
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
-                   (let* ((out (assoc-ref outputs "out"))
-                          (dxvk32 (assoc-ref inputs "dxvk32")))
-                     (mkdir-p (string-append out "/lib32"))
-                     (copy-recursively (string-append dxvk32 "/lib")
-                                       (string-append out "/lib32"))
-                     #t))))
-             '())
-         (add-after 'install 'install-setup
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (bin (string-append out "/bin/setup_dxvk")))
-               (mkdir-p (string-append out "/bin"))
-               (copy-file "../source/setup_dxvk.sh"
-                          bin)
-               (chmod bin #o755)
-               (substitute* bin
-                 (("wine=\"wine\"")
-                  (string-append "wine=" (assoc-ref inputs "wine") "/bin/wine"))
-                 (("x32") ,(match (%current-system)
-                             ("x86_64-linux" "../lib32")
-                             (_ "../lib")))
-                 (("x64") "../lib"))))))))
-    (inputs
-     `(("wine" ,(match (%current-system)
-                  ;; ("x86_64-linux" wine64)
-                  ("x86_64-linux" wine64-staging)
-                  ;; ("x86_64-linux" mingw-w64-x86_64)
-                  (_ wine)))
-       ,@(match (%current-system)
-           ("x86_64-linux"
-            `(("dxvk32" ,dxvk32)))
-           (_ '()))))
-    (supported-systems '("i686-linux" "x86_64-linux"))))